Driver software died :(


#1

The driver software for my Plugable USB 2.0 to 10/100/1000 Gigabit Ethernet LAN Network Adapter is not working and as a result my adapter will not work. have tried reinstalling driver software to no avail.


#2

Hi Jenny,

Thank you for contacting us! I’m very sorry your machine is experiencing a problem.

Can you say a little more about why you’re suspecting a problem with the driver software? Have you seen an error or is a problem visible in device manager?

Was the adapter working at one point, or never? And what operating system version is on your machine?

Stepping back and starting with the easy stuff, first thing to double-check is that the ethernet cable is solidly connected on both sides. Then, take a look at the “link” and “act” LEDs on the adapter - are they lit and/or flashing when the adapter is connected? What pattern do you see?

Thanks for supplying this extra info to get a picture of what’s happening! We’ll get this figured out.

Bernie


#3

The adapter was working at one point and then one day i tried to plug it in and my computer (windows vista, 32-bit) said "USB device not recognized, no driver software for this device is installed) so i installed it and once again it did not work and the same message appeared, so i tried reinstalling it and it still does not work. no lights lit up when i plugged it in.


#4

Hi Jenny,

I’m suspecting a unit that’s failed. We’d like to send you a replcement. Can you email your Amazon order # to support@plugable.com, and whether that original address is still good, and we’ll get a replacement off to you to confirm.

Thank you!
Bernie


#5