Driver for USB 2.0 ethernet adapter (10/100/1000Mbps) fails to install on Windows 7 (64 bit)


#1

I’ve tried installing the drivers from the supplied CD, allowing Windows to find the driver automatically and also downloading the AX88178_Win7_v1.x.3.8_Drivers_Setup_v1.0.1.0 software from the website. I removed the previous drivers each time before trying each type of install. All of these methods return the same error that the driver failed to install. The laptop is a Samsung Q430.


#2

Hi Sim,

Thanks for posting! I am sorry to know that you are having trouble with drivers for the Plugable USB 2.0 Gigabit LAN Adapter USB2-E1000.

Some quick questions to narrow things down -:

  1. When do you see the error? Is it at during the installation process or when the device is plugged in or …?

  2. What is the error code/message that is popped by Windows 7?

Once you post back with this information, we will figure out the next steps.

Thanks for your patience while we figure this out!

Regards,
Roze


#3

Hello

The installer completes fine, but the error occurs when I plug in the adapter for the first time. I see the error ‘Device driver software was not successfully installed’. The device manager shows ‘This device cannot start. (Code 10)’ I’ve attached screen shots below:

!](https://s3.amazonaws.com/satisfaction-production/s3_images/668287/error2_inline.png)](https://s3.amazonaws.com/satisfaction-production/s3_images/668287/error2.png) !](https://s3.amazonaws.com/satisfaction-production/s3_images/668289/error1_inline.png)](https://s3.amazonaws.com/satisfaction-production/s3_images/668289/error1.png)

Thanks


#4

Sim,

Thanks for the information and the screenshots! The two main possible causes of code 10 for this device are-:

  1. The device is not getting enough power

  2. The device is faulty

Is the Plugable USB 2.0 Gigabit LAN Adapter USB2-E1000 plugged into an inbuilt USB port on the system or through a hub? Could you unplug it and plug it into an (or another) inbuilt USB 2.0 port on the system, just to rule out a bad port (a port not providing 500mA of power)?

If it continues to show the same error on different ports, it does point to a faulty unit. If the root cause of the issue is a bad unit, we would like to send you a pretested unit to get you up and running at the earliest.

Please shoot us an email at support@plugable.com with your Amazon Order ID, Serial No (given on the back) of the device and the best address to send the pretested replacement and we will ship it to you.

Regards,
Roze


#5

Hi Roze

Thanks for the prompt response.

It’s not connected via a hub, it’s plugged directly into the laptop. I’ve tried it in each of the usb ports, but it fails to work in any of them. I’ll email you with the requested details for a replacement.

Thanks again for the help.


#6

I am having the same problem. Windows 7 on an HP Pavilion dv7. Same errors. Tried all inbuilt USB ports. I already tried a second USB-Serial adapter. To compound the issue, the driver download site is not responding for 2 days. (amazonaws, and it’s not my firewall). So I have only tried the CD and whatever Windows 7 doesn’t come up with. (Yes, UPDATE is on.). I could try it on another machine, but my other machines already have serial ports (and are running XP.) After instaling drivers, it shows up in DM as “Other devices” “no driver installed.”

After uninstalling, booting (just in case) and reinstalling from the CD, I plug in the device. It tellls me it is looking for the drivers, then says “Device driver software was not successfully installed. USB-Serial Controller D.”


#7

Sorry–my device is a USB-Serial adapter. Not the LAN adapter.


#8

Hi Duncan,

Thanks for posting your question here, do you have a Plugable USB to Serial adapter? The driver package only works with Prolific chipsets. The driver download is available at:

https://s3.amazonaws.com/plugable/bin…

Sorry if it wasn’t responding before, it’s up now so the first step in troubleshooting will be to get this driver package downloaded and installed.

You should then see a new entry under "Ports, (COM and LPT)

Let me know how it goes.
Thanks,
Jerome.


#9

I’m impressed! Thanks for the fast response.
>>>Thanks for posting your question here, do you have a Plugable USB to Serial adapter?

Yes, Plugable USB to Serial.

I was still unable to download the drivers from amazonaws on my W7 machine, but unlike yesterday I could download them on an XP machine. (I’m not sure what that was all about. Both machines are behind the same firewall and running Norton Security.) I installed on my XP, found the drivers (2 ser*.sys files) and copied them over to my W7 machine. Then I had to do a manual install (Device manager, …, update driver, browse for drivers) on my W7 machine. (I know, not always a good idea to cross-dress drivers but the code looked benign.) That all worked finally. Not sure how ordinary users would get this done (I’ve been doing this for >50 years.)

I suspect the main problem was the inability of my W7 machine to directly download the drivers. I am not sure why my XP machine could not do this yesterday, nor why the W7 machine couldn’t do it yesterday nor today.

Thanks again. I’m clam happy.


#10