Driver failure when replicating laptop on external monitor


#1

I am having trouble with my Plugable USB 2.0 Universal Docking Station when replicating the laptop (HP Pavilion dv9000 running windows 7) monitor on an external monitor (HP 2010i).

When purchased originally it worked beautifully, but later it worked for only a minute or so, and now I can not get it to work at all. I’ve tried installing the latest drivers (6.0.34621.0 & 6.0.34689.0) without success.

The event viewer is showing the following error:
“The DispayLinkManaager service is marked as an interactive service. However, the system is configured to not allow interactive services. This service may not function properly”

I also saw the following error when the dual monitor setup failed:
Log Name: System, Source: AX88772, Event ID: 17, Qualifier: 49152
Event Data: The following information was included with the event: Speed IO complete failed.

Any ideas what the problem might be?

–Robert


#2

Hi Robert,

Thanks for contacting us! We’ll work to help.

Can you check to see if the DispayLinkManager service is configured to “Allow service to interact with desktop” in Windows’ Services control panel? Here’s how: http://social.technet.microsoft.com/w…

In short, you can type “services” at the start menu search. Find DisplayLinkManager, right click for Properties, then go to the “Log On” tab, and you’ll see this option. It needs to be checked for the DisplayLink’s software to work correctly (this is the default; and isn’t normally a problem)

!](https://s3.amazonaws.com/satisfaction-production/s3_images/603302/Win7-Services-DisplayLinkManager-LogOn_inline.PNG)](https://s3.amazonaws.com/satisfaction-production/s3_images/603302/Win7-Services-DisplayLinkManager-LogOn.PNG)

Let us know what you see for that setting (and if enabling it fixes the issue). From that, we’ll be able to figure out next steps.

Thanks!
Bernie


#3

Hello Bernie. Thanks for the suggestion.

I checked and verified that the DispayLinkManager service is configured to “Allow service to interact with desktop”. What I saw looked just like your image so I did not make any changes.


#4

Hi Robert,

OK, good, at least it rules out that problem. I think the quickest way from here is to use DisplayLink’s tool for gathering logs on the system, to see if the problem jumps out.

Here’s how: http://plugable.com/support/tools/dis…

If you can email the .zip file this puts on the desktop to support@plugable.com, we’ll take a look at what’s happening.

Thanks for your patience!
Bernie


#5

I did send the zip file; let me know if it didn’t make it. I referenced this thread in the email.

Another data point: the same or similar behavior was reported on my clients laptop which I believe is a toshiba. I can get more information if needed. Might point to a defective docking station, but the log files may offer confirmation (or not) to that possibility.


#6