Drive not recognized on Win10 (multiple systems)

The NVME 3.2 gen2 drive isn’t recognized by Windows 10 on two systems (drive powers but doesn’t show in file explorer). Using Samsung 970 EVO plus. Also tried Crucial NVME and same issue. Tried on USB A with included cable and USB C with included cable. No go. What gives?


Thanks for reaching out to us, I am sorry this is not working as expected and I am happy to help!

Are both of the NVMe SSDs new drives, or have they previously been detected in Windows explorer using this enclosure?

New NVMe SSDs are not partitioned or formatted and are not expected to be detected in Windows file explorer, however they should be detected in both the Device Manager and in the Disk Management windows.

If these are both new drives that have not already been formatted, we have an instructional video here ( ) that covers the formatting process within Windows.

Please let me know if this helps, and if the drive or drives have already been formatted if they are being detected in Device Manager ( Right-click on the start menu and select “Device Manager”), they should show up in the “Disk drives” section, either by the name of the SSD, as JMicron JMS583.

Thank you, I look forward to hearing back from you.

Plugable Technology


We’re closing this thread due to inactivity, but if you have any further questions please feel free to contact and we’ll be happy to help.


Plugable Technologies