Dosen't work, no blue indicator lights, PC does not recognize hub


#1

I purchased a Plugable 7 Port High Speed USB 2.0 Hub with 3A Power Adapter model USB2-HUB-AG7 from Amazon, it worked for for a while but the blue indicator lights never worked and now my laptop does not recognize the device so I went back to using a cheap 7 port hub that didn’t have the power rating this hub has. But it works! The time to return it through Amazon has expired and is there a “fix” or firmware update that my fix this issue?


#2

Hi Glenn - Thanks for posting, and sorry about the frustration.

The 7 port hub has a single red LED that will be lit when the hub itself is getting power, and blue LEDs for each port, to signal when a device has successfully enumerated on that port. These LEDs are nice for debugging.

(more detail in the FAQ at http://plugable.com/products/usb2-hub…)

Especially if a simple USB device like a keyboard or mouse has problems; or if the red LED doesn’t come on when the hub’s AC power adapter is attached, or any of the blue LEDs don’t come on when you’re successfully using a device, then something isn’t right about your unit - we’ll be able to help.

Just email support@plugable.com with your Amazon order number, and we’ll get you fixed up. It doesn’t matter that you’re over the 30 days with Amazon … the product has a one year warranty, and try to be quick about exchanges if anything is wrong.

Thanks for contacting us so we can help!
Bernie


#3

The hub was functioning for about 2 weeks and then no blue light would come on
no matter what port I was using. This was the case for a printer, an external hard drive and a scanner. I have a new Imac.


#4

Hi Peter,

Thanks for posting here! Just shoot us an email at support@plugable.com with your Amazon Order ID along with information regarding your setup and the issue and we will get you up and running.

Regards,
Roze


#5