Docking Station worked then "not recognized"


#1

Hello…I recently purchased and have been using your dc-125 model docking station. It set up brilliantly and was working great switching from laptop to laptop, but yesterday I plugged in my machine to the station and it popped up saying “usb device not recognized” The strange thing is that the sound still runs through the docking station, but I can get no visual. I tried reinstalling drivers to no avail…any help would be greatly appreciated


#2

Hi jjziser,

Thanks for posting your question here. The most likely reason for the change in behavior is that the dock is not getting enough power. Has there been any change in the way it’s connected?

Is it connected directly to the computer? Do the USB ports on the DC-125 still work? Try them with something simple like a USB mouse and keyboard.

Let me know these additional details and we’ll figure out our next steps.

Thanks,
Jerome.


#3

Hey Jerome,

There has been no change in the way it connects from the time of install. The docking station connects directly to a laptop. The USB ports are still functioning and still show on the laptop when connected. It is just the display that is not coming through. I also get a message when i connect the station that tells me that the USB device is not recognized.


#4

You mentioned power…is there an adapter you recommend?


#5

Hi jjziser,

If you look in device manager do you see the same two devices as in this screen shot?

!](https://d37wxxhohlp07s.cloudfront.net/s3_images/730118/dc125-devicemanager-circled-devices_inline.PNG?1335299965)](https://d37wxxhohlp07s.cloudfront.net/s3_images/730118/dc125-devicemanager-circled-devices.PNG?1335299965)

If so, it’s possible we’re having a driver issue. Run the DisplayLink support tool and send the output to support@plugable.com. Here’s how:

http://plugable.com/support/tools/dis…

If not, please send your Amazon order id to support@plugable.com and we’ll figure out our next steps.

Thanks,
Jerome.


#6

I don’t see the “USB Display Adapters” in there nor “DC-125”. I will send my order ID…thanks :slight_smile:


#7

Thanks,
Jerome.


#8