Docking Station UD-3000 software unstable


#1

Hello,

I’ve purchased the USB 3.0 Docking Station UD-3000 to connect to my new Lenovo Thinkpad Helix (Windows 8 Pro). The DisplayLink driver (May 10 release) installed fine and I can use the USB ports, ethernet, and use an external monitor… but it renders my Helix unusable. Unable to launch any programs, Task Manager, or Display Settings. Nada. The app icons in the “All Apps” Metro view are blank. Can’t shutdown without holding the power button down for 5 seconds.

I did this a few times before I disconnected the UD-3000, rebooted, and the laptop worked great. Uninstalled the DisplayLink software and now everything is fine.

I searched but didn’t see anything specific about Windows 8 installations. I’m *really* hoping to get this working because I want to get a second docking station for my home office. Please advise.

Tony


#2

Hi there,

Thank you for posting here, we’d be glad to help! Since the latest DisplayLink driver is still fairly new, let’s first test to see if the previous version DisplayLink driver v7.2 M0 yield better results on your system. Here are the steps to install:

  1. Disconnect the dock from the computer and run the DisplayLink Cleaner tool to completely uninstall existing DisplayLink Software:
    http://displaylink.com/techsupport_fi…

  2. Download v7.2 M0 from the below link and follow the installation prompts.

http://plugable.s3.amazonaws.com/bin/…

  1. Reboot the computer and reconnect the dock

Let me know what you see at this point and if the behavior is any different!

Thanks,
Ellen


#3

Thank you for your prompt reply!

I ran the Cleaner and installed v7.2 M0, as instructed. It did the same thing. Although this time the “All Apps” icons were fine, but some of the large app icons on the Metro main screen were blanked out.

I have a Microsoft Surface Pro at home. I can try tomorrow. Although the Helix is going to be my primary device (it’s awesome!). Let me know if you have any other suggestions.

Tony


#4

Okay thanks for testing that! It would be very helpful if you could capture and send us the DisplayLink log file from your Helix system, it gives us detailed information on how your system is setup and helps us narrow down the problem. Step by step instructions on how to collect this log file can be found here:
http://plugable.com/support/tools/dis…

You can send the zip file to support@plugable.com with a link to this thread and we’ll take a look!

Thanks,
Ellen


#5

Thanks, Ellen. I sent the log file. I look forward to getting this working.


#6

Was anything ever resolved here I have the lenovo Helix and looking for to purchase the Plugable UD-3000 USB 3.0 Universal Docking Station but doing a quick google search brought me to this page. So I thought I would ask the above question. thanx stacey
P.s. will check back for reply.


#7

It was a bad device. I had it replaced and the new one worked.


#8

thank you for your prompt reply, I see the Plugable UD-3000 USB 3.0 Universal Docking Station gets really high reviews on amazon. so I believe I will jump in and purchase one.
thanks agian.


#9

Thanks for replying, machovato!
And thanks for asking Stacey - if you do have any trouble at all, just email us at support@plugable.com, and we’ll be happy to help, thanks!


#10