Docking station turned monitor to paper weight!


#1

I set up my new ud160 yesterday with a new monitor (desktop widescreen connected via vga/dvi adapter) and everything worked great. I shut down the system and went to bed and this morning it will not recognize the monitor. Running windows 7 64 bit professional. I’ve unplugged, rebooted replugged about a bazillion times. How do I fix this? Also, I bought the unit from Amazon. Could I be suffering from a bad dvi port like the other poster? or was it an update? I only want to use system restore as a last resort. All other peripherals are operating fine via USB connections.


#2

Hi Michelle - If any monitor is black/not recognized, it’s almost certainly DisplayLink’s software update, not any kind of hardware problem.

It sounds like yours is the 3rd report of this, this morning (two of them on Windows 7 64-bit).

We haven’t yet been able to reproduce this problem here, so we’re scrambling to understand what portion of systems are affected. And of course, we’ve contacted DisplayLink to get whatever info they have.

To avoid System Restore, what I’d recommend is this: go to http://displaylink.com/support/downlo… and first try installing the latest 5.5 beta. If that doesn’t work, uninstall the Displaylink Core Software (from Windows Control Panel->“Programs and Features”), and then actually go back a few versions and install the latest displaylink 5.3 drivers. Thanks for letting us know results!

And thanks for your patience while we figure this out!


#3

For the benefit of everyone else, here’s what we saw on Michelle’s system:

The DisplayLink device was banged out (yellow exclaimation) in Device Manager, with the message “Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)”.

Michelle’s system had the DisplayLink driver version 5.3.25973.0, which is the same version currently being pushed out by DisplayLink auto-update.

So it appeared to be a driver signing issue with some portion of that driver package.

We asked Michelle to install the latest DisplayLink drivers - the 5.5 beta from http://displaylink.com/support/downlo… and that completely resolved her problems - docking station and monitor up fine. Everything working.

So we still have more investigation to understand what systems are affected (since not all are), but we’re getting closer to understanding what’s happened this morning with these updates.


#4

Problem solved! Tech support (Bernie) was unmatched in responsiveness - Microsoft could sure learn a thing or two from Plugable- Couldn’t be more pleased - Thank you!


#5