Docking station not showing up in Disk Utility on MacOS


#1

I have an issue with connecting usb3-sata-uasp1 to my macbook with mac os 10.9.5. When connected to the laptop I can feel the disk inside spinning, but the blue light not turning on and I can not see the disk in the Disk Utility. I tried to connect it to dell windows 7 laptop and everything works fine. I can see and access the disk there.
Could you please confirm that this model works with mac computers and how can I set it up to work with one.
Thank you!


#2

Hello Tiflis,

Thanks for contacting Plugable! Sorry to hear that your USB hard drive dock is not working as it should.

Note that most hard drives formats will work for Windows OR Mac, not both. In other words, it is common for a Windows-formatted hard drive to not show up in Mac computers.

First - are you using a brand new hard drive, or a hard drive that was previously installed somewhere else?

Here are links to get started depending on which type of hard drive applies to you. Let me know if any particular step is an obstacle.

For new hard drives:
http://plugable.com/2015/03/12/settin…

For hard drives with existing data:
http://plugable.com/2015/03/12/recove…

Next, there are a few troubleshooting steps that you can perform to isolate the cause of the issue:

  1. Test the same hard drive and dock in a different computer to eliminate any potential issues with your current computer (sounds like you already confirmed this)

  2. Test the same dock with a different hard drive in the same computer to eliminate any potential issues with your current hard drive

  3. Test a different USB cable with the dock if you have one available to eliminate a potential bad USB cable

If the issue seems to follow the dock after the above troubleshooting steps, it may be defective. In that case, please email support@plugable.com and we can help with a remote fix or replacement.

Let me know what you find out and I can provide next steps!

Thank you,
Jordan
Plugable Technologies


#3