Do I have a lemon?


#1

Plugable 7-Port USB 3.0 Hub – just rec’d from Amazon and set up. 3.0 speeds not attained. 3 files of about 2.5 gb in size took about 120 seconds to transfer (WD My Passport 3.0 to new {late 2012) iMac while direct plug-in to Imac took 23 seconds. The hub also has 3-2.0 connections and all 4 blue lights are lit. Is it just a defective hub?


#2

Hi Map-

Thanks for posting with your findings, sorry to hear about the issues you’re having getting your external drive up and running at “SuperSpeed.”

The 1st quick troubleshooting tip I can recommend is to make sure your hub is connected to AC/wall electricity before connecting it via USB to your Mac. If everything is already setup this just means unplugging the USB cable from Mac to hub, and re-plugging after 30 seconds or so. If this doesn’t help (which I doubt it will), read on.

Another known issue discussed on Apple’s site is as follows:
“How do I get the best performance from the USB 3 ports?
The first device you plug in will configure the port, so always connect USB 3 capable hubs or devices first.”
http://support.apple.com/kb/HT5172

In the lab I have occasionally seen that a USB 3 device will only operate at USB 2.0 speeds if connected to a port that has been used previously (since the last reboot) with a USB 2.0 device. To be clear, I have seen cases where simply connecting a USB 2.0 device, removing the USB 2.0 device, and then connecting a USB 3.0 device to the same port caused the USB 3.0 device to work at USB 2.0 speeds. Rebooting is the only way to resolve this error, doing so while the USB 3.0 device is connected is recommended.

Please let me know if either of these is helpful. If not, there are other steps we can look into.

Best wishes-

Jeff Everett
MCITP Enterprise Support Technician
Plugable Technologies


#3

Thanks for the input Jeff. Unfortunately, neither idea worked. The transfer speed in each case was at 2.0 speeds. Would appreciate hearing of the “other steps” you mentioned.

Marshall Perry


#4

Hi Map,

Thanks for taking those troubleshooting steps, sorry to hear that your drives are still running at less than optimal speeds.

I just want to make sure that I’m understanding the symptoms correctly so tell me if I have this right –

  1. 4 of the blue lights are lit on the hub with nothing plugged in?

  2. After rebooting your iMac and first connecting your WD myPassport to the USB 3.0 port on the iMac you get USB 3.0 speeds. Then you put the hub in between and the speeds slow down?

It’s important to connect the USB 3.0 drive to the port on the iMac first so that it will configure the port as USB 3.0. One of the bugs in Macs 2012 USB 3.0 systems can get a port stuck in a slower mode if a slower device is connected first after reboot. You’ll want to use the drive to configure the port and then connect the hub.

Let me know these few details, first about the lights, and then what kind of speeds you are seeing when connected directly and we’ll figure out the next steps.

Thanks,
Jerome.

Plugable Technologies


#5

Jerome:

  1. the 3 blue lights I have on right now all relate to plugs that are in (i.e. I’ve never had the lights appear without a corresponding plug).

  2. a) I rebooted my Imac with my 3.0 WD drive plugged into IT. I copied a file from my Imac onto the 3.0 WD drive and the speed was very fast, easily 3.0 (less than a minute to copy a 2 GB file.; b) I unmounted the 3.0 WD drive and plugged Plugable into that same USB slot on the Imac; then I plugged the 3.0 WD drive into Plugable; I then tried to copy the same file from the Imac on to the 3.0 WD drive. It was very slow and didn’t even seem to be 2.0 level.


#6

Hi MAP,

Thanks for taking the time to verify that for me and double-checking the port configuration. I’d like to get tested unit running the latest firmware to you. Please send an email to support@plugable.com including a link to this thread, your Amazon Order Id and the best address to ship to.

Thanks.
Jerome.


#7