DL-195 caused me to reinstall my MacBook Pro :-(


#1

DL-195 caused me to reinstall my MacBook Pro :frowning:

Hi, I got a MacBook Pro 15", with i5 CPU, running Snow Leopard 32 bit. I got the Plugable UGA-2K-A DisplayLink DL-195 chip, The driver is 1.6 beta 3. The DL device successfully extended my Mac into two monitors; it’s a brilliant solution for my office setup, I love it but…

When I took my MacBook home and started it up (without the DL device) - it more or less stuck upon startup with a blue screen, and various screen artifacts. I didn’t know realize it was the missing DL device which caused the problem, and after many hours of troubleshooting I settled on reinstalling my entire system, taking up the entire Halloween weekend. Very frustrating…

In retrospect, all I had to do was connect the Mac to the DL device. Regardless, I’m still stuck with the same problem - whenever I restart the mac and the Pluggbable device is missing - I’m screwed…

Any help will be appreciated.


#2

Thanks for the info, indeed I missed out on that product warning, though I assumed some features are limited and bugs are expected (as the driver is in Beta mode).

Fortunately, I mostly work on Windows 7 (on the MacBook) which doesn’t have a similar problem. I read the interesting article you linked to - very informative, thanks. I think I can work around some of these solutions.

Thanks again for the quick response. I love the product, kudos for the sweet site too!


#3

Hi -

A reinstall on Halloween is a horror no one should have to live through! I’m very sorry!

Unfortunately, this problem is what caused us to list the UGA-2K-A as not compatible with recent MacBook Pros (the 15 and 17 inch versions). We include that compatibility info in the Amazon product description, and have tried to provide regular updates about it (e.g. http://plugable.com/2010/10/20/macboo… ). But we also know how easy it is to miss a note like that. There’s unfortunately so much text on an Amazon product page.

The problem is the switchable Intel/nVidia graphics which is a feature unique to the 15" and 17" MBPs. It’s not currently in any other product (the 13" MBP is fine; Macbooks and airs don’t have it) – and hopefully won’t be continued by Apple in future products.

Fortunately, there are (arguably tolerable) workarounds the user can do. Here is a good post with background on the problem and the options for resolving it. Please read through this for the full details:
http://www.displaylink.org/forum/show…

With the workarounds in that post (e.g. turning off automatic graphics switching), confirm that your problems are solved.

Please let us know if this helps. If not, we’ll dig deeper.

Again, my apologies and thank you for posting about this frustrating problem!
Bernie


#4