DL-165 doesn't come back on after exiting Sleep on Mac OS X Lion 10.7.4


#1

I just purchased this USB to DVI adapter so I can add a 3rd monitor to my work iMac, and whenever I leave my desk I put the machine to sleep with a password required for it to come back on. The monitor connected to the USB to DVI adapter is not in sleep mode, but it has been dropped from the displays and won’t come back without a reboot. I have the latest drivers and have tried reinstalling them, and I can’t reboot each time I come back to my office. Any suggestions?


#2

Hi Matthew - Thanks for posting - we’ll be able to help.

DisplayLink current knowledge base on this issue is here:
http://www.displaylink.com/support/ti…

But 10.7.4 has shifted behaviors in several areas, so it may be a combination of that and the iMac that we need to research.

Two quick questions:

Do you have any USB hubs in the mix?
Can you say which model of iMac you have?

Thanks for this additional detail!
Bernie


#3

One of the monitors (they’re both Dell 2007FP) has a USB hub hooked up to the iMac. It has 2 USB ports that connect via cable back to the iMac. That Dell monitor is working just fine and is connected via mini-DVI. I’m not using the hub on the monitor connecting via the USB adapter.

The iMac is a 27-inch, Late 2009 model:

Processor: 2.8 GHz Intel Core i7
Memory: 8 GB 1067 MHz DDR3
Graphics: ATI Radeon HD 4850 512 MB
Software: Mac OS X Lion 10.7.4 (11E53)

Edit: Just read the KB article. The USB to DVI adapter is not connected to a USB hub.


#4

Just unplugging and plugging the adapter doesn’t cause it to be recognized again?


#5

Hi Matthew - trying Brook’s suggestion would be a good clue for us, in any case.

DisplayLink’s latest release notes ( http://displaylinkreleasenotes.s3.ama… ) mentions the Mac limitation that a change of monitor requires unplug / replug.

We would like to figure out if, on resume from sleep, the software may be seeing the monitor arrive a few seconds late, triggering a perceived “change of monitor”. Since we haven’t seen this on other 10.7.4 systems yet, it could be a timing issue based on the speed on the machine.

Thanks for helping us to track this down. If there isn’t an acceptable workaround, don’t worry, we’ll never leave you stuck with hardware that isn’t meeting your need.

Thanks again for your patience,
Bernie


#6

No, unplugging it and plugging it back in does not resolve the issue. Nor does clearing all display settings on OS X, nor does forcing OS X to detect displays.


#7

Hi Matthew - It sounds like the only way you’ve found to get the display back after sleep is a reboot. Is that right?

Sorry, as far as I can tell this isn’t a widely seen problem – the Mac has lots of unique issues with each version of the OS + 3rd party drivers, but we don’t have another instance of this exact symptoms here (where a reboot required), and didn’t find another case in searches across all brands of DisplayLink products, so we need to track down what is different here. It’s probably something simple.

Two things to check to run this down further:

  1. The Mac has one characteristic which is different from Windows: It disables USB ports on the system if any downstream device asks for more power than the system and hubs theoretically offer. Only a reboot will bring that port back. If that were the case, then switching ports would work. Does the display also not come back if you unplug and then replug into a different port? The answer to that will rule in/out that cause.

  2. And then to get some deeper info, would you be willing to run DisplayLink’s support tool and email support@plugable.com with the file it generates? Here’s how: http://plugable.com/support/tools/dis… (Mac info in the second half)

This will give us information on specific versions of software and hardware that are in play.

Please let us know if you’re running short on time / patience – we make returns easy, so you always have an out if you don’t have the time available to work with us to solve the issue. Just let us know if you’d like to go that direction, it’s no problem.

That said, we’d love to understand and solve this issue.

Thanks for your patience!
Bernie


#8

Bernie,

I think that’s a neat idea and observation regarding USB ports and how Mac powers them. That doesn’t seem to be the case here, though, as I swapped the video adapter with my keyboard just now. Keyboard works, and video doesn’t.

I’ll run the support tool later this afternoon if I have time (and if not, I can get that to you tomorrow). I don’t want to return the device if I can avoid it because I don’t know that there’s another good USB-to-DVI adapter with OS X drivers out there, but we’ll see.

One more thing I didn’t mention, and which I don’t see being a problem but I may be horribly wrong: I run Parallels with Windows 7 on this iMac, and whenever a USB device is connected, Parallels asks if you want the USB device to connect to Mac or Windows. Of course, I tell it to connect to Mac, and it works on boot and after Parallels has been launched. In one test, it even worked after a short screen lock (all screens dark, enter password to bring everything back up), it just didn’t work after a longer screen lock and sleep. I don’t know if that helps or not, but that’s all the information I have.

Also, thanks for sticking with me on this. I don’t generally expect this level of support directly from the company and it has been refreshing. I hope we can make this work, especially since I have other staff who are interested in running multiple monitors and need a solution like this. (We had visited another campus that used an HP device, but they were running Windows only and I wasn’t sure those would work on OS X.)


#9

I stand corrected. Parallels is exactly what the problem was. I was rebooting the machine to test a solution and Parallels shut down but Chrome didn’t, thereby halting the reboot. After Parallels shut down, the third monitor (on the USB adapter) came back on.

I put the iMac to sleep for an hour over lunch, came back, and the third monitor comes back on as expected.

So, something in how Parallels intercepts and then routes USB devices is the culprit here. It means potentially killing Parallels regularly, which is a bit of a problem, but it’s not as bad as a reboot, and now that I know the issue isn’t with my base operating system, I can live with that. I just wish I didn’t need Microsoft Outlook (on Windows) so much!

Thanks again for all your help. I’m going to do some testing with Parallels and see if I can find a faster resolution than restarting that application.


#10

Hi Matthew - Thanks for tracking down that Parallels seems to be inappropriately latching onto the device after sleep!

Parallels is a great VM and pretty common, so this is really helpful to know – I’m sure you’ll not be the only one to run into this eventually.

I’d recommend starting with this workaround of closing parallels to get the device back, and then perhaps contacting Parallels to see if it’s a known issue and if there’s any workaround.

And please let us know if we can do anything at all from our side – we’ll help in any way we can.

Thanks again!
Bernie


#11

Next stage of troubleshooting athttp://forum.parallels.com/showthread….


#12

One final update. Parallels customer support has reviewed their support logs that I provided, system and application logs from Event Viewer on the Windows VM, and some other logs from OS X. In the end, they were unable to resolve this issue and have passed it on to their development team. Perhaps it wil be fixed in a future version of Parallels, but for now I will continue using the Suspend trick to keep things running.

Thanks again for your help, Bernie!


#13