Displays freeze a few times a day


#1

I use many different display link USB 3 docking stations at my company. Most of my users have issues with the screens freezing that can be resolved by unplugging the USB cable and plugging it back in. While this doesn’t seem like a huge deal, for us it is very disruptive because it kills the network connection and causes our primary application to lock up. The only way for users to get back to work is to submit a help desk ticket and get their user account unlocked.

I have tried different brands of docking stations, but they all have the same problem. Most of my docking stations are plugable. I have tried uninstalling the display link driver and installing the latest version and it never really seems to improve things for us.

Is there anything else I can do to try to improve this situation? If this is a known issue, are the 4k docking stations affected the same way? I have no need for 4k video, but I will spend more money to get a working docking station.

Thank you for your time,
Eric


#2

Hi Erik,

Thanks for posting and I would be happy to help with your docking stations.

The behavior you describe is not typical as we have many customers using our docks in the hundreds at several locations and some with thousands (all of our DisplayLink-based docks behave in the same manner, regardless of whether or not they support 4K). As the behavior affects multiple brands of DisplayLink-based docking stations across multiple users, based on your description our next step is to get more information to see if we can help determine the cause of the behavior that is specific to your environment.

If you would, just after the bad behavior has occurred on a single system using a Plugable docking station, please keep everything connected (even though the dock has stopped working) and send the output of our diagnostic utility PlugDebug --> http://plugable.com/support/plugdebug to support@plugable.com with ‘For ticket 174448’ in the subject line. This will allow us to match everything up and examine some log files from the system to help determine the next steps. You can download the application in advance to have it ready and it does not require network or internet access to run.

If you could also include in your email the exact steps to reproduce the behavior as well as an Amazon Order ID number for one of your Plugable docking station purchases (don’t post that here in the public forum) that would be most helpful.

Thank you,

Bob
Plugable Technologies
www.plugable.com/support


#3

I will give it a shot. AWS seems to be having trouble and I can’t download the debug utility right now, but I will try again tomorrow.


#4

Thanks Eric, please just send us the file as time allows. To the inability to download the PlugDebug utility, our downloads are powered by Amazon’s AWS and Amazon is having some technical difficulties this afternoon (https://techcrunch.com/2017/02/28/ama…)

Hopefully Amazon will resolve the issue shortly. Thanks for your patience!

Bob


#5