DisplayPort not working with Dell XPS 15


#1

I have the USB-C 4K (UD-ULTC4K).
I have a Dell XPS 15 (9570).
I have 2 Asus 24" monitors (VE248H, mfg 09/2017). They have VGA, HDMI, and DVI.
I purchased a Cable Matters DisplayPort to HDTV cable (actually it was a 2-pack) (102003-6 x2).

I would like to use - ideally, 3 (2x DP and 1 HDMI) - or minimally, 2 (1x DP and 1HDMI or 2x DP and 0 HDMI) - monitors connected to the docking station.

I’m able to connect to either monitor via the HDMI port (using a standard HDMI cable), but when I try to use the above cables to go from the DP on the dock station to the HDMI port on the monitor - nada.

Do I have the wrong cables I’m assuming the cables (which I purchased on Amazon) are passive, but I don’t think I need active?

Thoughts?


#2

Hello,

Thank you for contacting Plugable support! Sorry to hear about this issue. I’d be more than happy to assist you.

Those cables should work with the dock as the dock is DP++ capable and supports passive cables. Since they’re not working, let’s get a closer look at the system to see what might be going on.

We have a troubleshooting tool that helps us find out what is going on in situations like this. Please plug the dock with your monitors attached into your computer, then go to this page and follow the instructions there:

http://plugable.com/support/plugdebug

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry

Senior Engineer
Plugable Technologies


http://plugable.com | http://performance.plugable.com/


#3

Joshua,

First off thank you for the quick reply - one thing I’ve noticed here is that all responses I’ve seen from Plugable employees are professional, kind, and genuinely wanting to help. So - kudos to you and the team there.

Second - and most importantly - my problem seems to have corrected itself. I downloaded the debug tool as you indicated, and when I connected the monitor via the DP-HDMI cable this time - voila - it worked! I’d spent a bit of time (in both Ubuntu and Windows environments - I have dual boot) - troubleshooting before I opened this case. I’m not sure what changed, though I did go in and configure the displays (Windows) to extend rather than mirror before trying this time. When I rebooted back in to Ubuntu it just worked there too; it’s in Ubuntu that I’d spent most of my time trying to resolve this.
I’m sorry I don’t have a definitive answer as to what resolved it (perhaps just plugging it back in to the monitor!), but I appreciate the help; you can close this case.

Thanks again,

Chuck


#4

You’re most welcome Chuck!

Also, thanks for the update about this issue! Interesting that it’s been resolved seemingly on its own, though we do see this kind of result from time to time. Sometimes the act of unplugging and replugging external accessories can work as it forces the dock to redetect hardware.

Please do let us know if you encounter further issues and we’ll be more than happy to assist you if needed.

Best wishes,
Josh


closed #5

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.