DisplayLink work on Ubuntu Server without any desktop managers?


#1

Hi,

I own an Acer H340 NAS that doesn’t have a graphic card. I have Ubuntu Server 12.04 installed on it. I plan to purchase a Plugable usb to hdmi adapter and set up per these http://plugable.com/2011/12/23/usb-gr… instructions. I have X11 installed, but no desktop manager (gnome, kde, xfce, etc). When I boot up the machine, it should show a terminal waiting for login. Would this device show the terminal, or would it only work if I have an X-based desktop manager installed? Thanks.


#2

Hi vinhdizzo - thanks for asking ahead!

First off, I have to warn that things can get complicated fast on Linux. We can’t help with everything - those it’s definitely for advanced users only.

With that said, as long as udlfb, the kernel driver in Ubuntu 12.04 that matches against all our USB 2.0 graphics devices like the Plugable UGA-165 http://plugable.com/products/uga-165/ has the udlfb kernel module option ‘console’ enabled (which I believe is on by default in Ubuntu 12.04), and the kernel has the ‘fbcon’ and ‘console’ modules loaded and not blacklisted – then if our USB graphics device is the only device on the system (it’s getting assigned /dev/fb0), then you’ll automatically get a text login when you boot up.

From there, you can have a xorg.conf like in the blog post you referenced, which then loads X on that same /dev/fb0

Hope that helps!

Note we’re soon going to have USB 3.0 devices, and those are a new DisplayLink chip that’s Windows only for now. So avoid those if you’re thinking about Linux.

Thanks again!
Bernie


#3

Bernie, thanks for the reply. On my NAS, dmesg shows:
fb0: inteldrmfb frame buffer device

Sometimes it also shows fb1.

So, does that mean it won’t work?

I actually bought a similar usb to hdmi adapter at the local store. Box shows Linux support. I tried it on my netbook per that post I referenced (I changed fb0 to fb1), then the adapter works.

When I tried it on my NAS (set to /dev/fb1), things doesn’t work after restarting the computer (get blank). When I unplug and replug, dmesg shows /dev/fb2 fb3 and fb4 found. Output of adapter is green.

What are your thoughts? USB to HDMI probably isn’t going to work on my NAS right?


#4

Hi - Yes, unfortunately. You’ll likely get the same result with all USB graphics adapters (that have a in-kernel framebuffer driver).


#5