DisplayLink video driver will not install

Hello. I am trying to install the DisplayLink video driver for my UD-3900H Plugable USB 3.0 Hub. When I run the install program it performs a System Check and says it has passed and installation can continue. Then the options are upgrade or cancel. If I try to upgrade, it asked if I want to cancel the installation. If I say yes, it cancels and it closes. If I say no, it goes back to saying the compatibility check has successfully passed and my options are upgrade or cancel.

Your assistance is requested.

Hi Michael,

Thank you for contacting support. I understand you have a UD-3900H and are trying to install the latest DisplayLink drivers and I would be happy to help.

At your convenience, could you please collect a set of diagnostic logs generated by our PlugDebug utility? It will gather device information and installation logs that will help our support team understand what could be happening.

To collect these logs, please have the device plugged into your computer, then go to this page and follow the instructions there:

https://plugable.com/support/plugdebug/

The tool will collect system logs into a ZIP file and save them to your Desktop so they can be attached to your email reply. These log files combined with the problem description you’ve provided will help us understand what’s happening and provide the best next steps.

Best regards,

Michael S.

I tried to install both versions of the debug tool and it they don’t finish installing. it prompts for admin credentials, they are provided, and then it just closes.

Ok, I did a bit of brute force on the debug install, but I got it installed. And the file is sent

Hi Michael,

Thank you for providing your PlugDebug file. That is appreciated.

At this point let’s go ahead and perform a ‘clean’ manual installation of the latest version of the driver. During these steps, we will utilize DisplayLink’s installation cleaner utility to see if we can resolve any issues you are experiencing while attempting to install the driver. To do so, please follow these steps:

  1. Please disconnect the dock from the system and please disconnect the power cable from the dock so it turns off completely (this is important so the unit resets). Please keep everything disconnected until the last step.

  2. Uninstall any and all software with ‘DisplayLink’ in the title that is present from within the Control Panel -> Programs and Features. Don’t worry if these entries are not present or if the process does not work, please just move onto the next step.

  3. Download and run the DisplayLink Installation Cleaner utility, found here --> https://s3.amazonaws.com/plugable/bin/DisplayLink/DisplayLink+Installation+Cleaner+9.1.1462.exe and ensure it displays “Cleaning Complete” when done (video walk-through if you need it -> https://youtu.be/AcVV1gD_FvI)

  4. Once the Cleaner has been run, reboot the system (even if not prompted to).

  5. Now download and install the 10.0 M0 DisplayLink software driver, found here --> https://plugable.s3.amazonaws.com/bin/DisplayLink/DisplayLink+USB+Graphics+Software+for+Windows+10.0+M0.exe

  6. Reconnect the power cable to the dock first. Once the dock is powered on (a blue light will be present on the front), reconnect it to your system. If the device is not detected, please reboot the system.

If that does not help with the behavior, just after the problem has occurred again, please keep the dock connected to your system (even if not working as expected) and please run PlugDebug one more time and send us the updated file to support@plugable.com so that we may determine the next steps.

If you could also please include the Amazon Order ID number that would be appreciated.

We appreciate your patience regarding this matter, and we thank you for giving us the chance to help.

Best regards,

Michael S.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.