Displaylink Network Adapter NCM failed


#1

HP Mini 1104. 1 gb RAM, Window 7 Pro. Connected to a UD-3000.

I was having some video issues which were solved by installing DisplayLink 7.2. During the install, all devices were successfully setup (mouse, keyboard, audio, display) except I received theerror: Displaylink Network Adapter NCM. Windows Update finds nothing to update. I can connect to the network however the connection is so slow that I can’t open sub-directories - especially when I am several sub-directories deep. Explorer will say “not responding”.

The network is very fast if ethernet cable is plugged directly into the network instead of the UD-3000.


#2

Hi Kathy,

Thanks for posting your question here, we’d be glad to help! A couple of questions to get us started:

  1. Did you experience any slowness with the network on the dock prior to upgrading to 7.2 or was it only after the upgrade?

  2. If you unplug the power cord to the dock and re-plug to reset the firmware, does that make a different in the network speed?

  3. Is the dock connected to a USB 3 or USB 2 port on the laptop? Does it make any difference if you swap ports?

Thanks for any additional details you can provide!

Thanks,
Ellen


#3

I did not notice this problem until after 7.2.

Unplugging power does not seem to solve the problem.

Despite only being 6 months old, I only see USB2 Enhanced Host Controller listed once despite having 3 USB ports. The rest just say USB Enhanced. Could this mean USB1? I have no idea which is which though. But clearly there are none marked USB3 in the device manager.

I did move the dock to a different USB port and it worked better SOME of the time…

With the Dock plugged into a different USB port, is there a way to get back to the install screen so I can see if this time it says something other than “failed” next to “Displaylink Network Adapter NCM”


#4

Hi Kathy,

Per our email exchanges, let us know if there are still issues once you’ve had a chance to reload the driver as well as resetting the firmware on the dock!

Thanks,
Ellen


#5

Just for the benefit of others: Kathy uninstalled and run the DisplayLink Cleaner utility to make sure everything was gone:
http://www.displaylink.com/support/ti…

And reinstalled the DisplayLink drivers. That solved the issue.

Thanks to Kathy for her patience in working through it!
Bernie


#6