DisplayLink installer has detected that your USB 3.0 host controller drivers


#1

After having to unplug my UGA-165 adapter to move my system, I plug it back in only to find my adapter is not compatible with my system as Windows had updated to USB 3.0. I did the following:

You would need to update this driver first. Please go to -> https://downloadcenter.intel.com/Deta… download and install this driver (be sure to reboot after this procedure) and repeat steps 1 - 6 again. Please let me know how this turns out.

  1. Disconnect the all USB devices and peripherals from the computer
  2. Uninstall DisplayLink Core software from Control Panel -> Programs. Do not worry if this fails, just move onto the next step.
  3. Download and run the DisplayLink cleaner tool -> http://displaylink.com/techsupport_fi
  4. Once the Cleaner has been run, reboot (do not close the window until you see the message “Cleaning complete. Press ENTER to end.”)
  5. Now download and run the latest DisplayLink software from our downloads page -> http://www.displaylink.com/support/sl
  6. Reconnect the display adapter directly to the computer.

LED does not light as well. Not sure if it’s the hardware or the drivers.


#2

Hello John,

I am sorry to hear this. This looks like you have had a support ticket with us before. I would need to take a fresh and closer look to see what is going on. Please contact me directly at support@plugable.com and use “Ticket #82258” as a subject for reference to this conversation. Please also attach a PlugDebug (attachments cannot be shared on this forum -> http://plugable.com/support/plugdebug).

Kind regards,
Patric
Plugable Technologies


#3

Hello John,

Following up on my last message. Do you still need any assistance?

Kind regards,
Patric
Plugable Technologies


#4