Display not detected for USB 3 on Mac book calatina. Screen recording not allowing displaylink

Hello, I recently purchased the USB 3.0 UD 3900 docking station, and I am having trouble to get it to work with my mac. I have a macbook pro running Catalina 10.15.7. I can plug in the monitor directly to an HDMI adaptor and the display works fine, but if I plug it into the docking station, in the HDMI or the other monitor slot it does not work. Please note that I followed your instruction and installed the displaylink manager 1.5 (build 58125). the installation procedure went well but unfortunately, I am not prompted to authorize displaylink in the screen recording. When I go to screen recording in system preference and security & privacy, I don’t see displaylink there. I need help otherwise I will return the Docking station.

Hello Robert,

Thanks for contacting Plugable support! I’m sorry to hear about this display issue through your Plugable docking station, but I’d be happy to help!

the installation procedure went well but unfortunately, I am not prompted to authorize displaylink in the screen recording.

This is why you may be seeing this issue with your monitors.

The screen recording function is an enabled function that allows DisplayLink to access the pixels it needs to render a mirrored or extended screen and send the pixels over USB from your computer to the DisplayLink display. Additionally, there is no data being sent back to DisplayLink. To help further explain, I provided a link below.

Let’s run a clean install of the DisplayLink software.

The first step we’ll want to take is to make sure that the software used by the dock is in a good state by removing any DisplayLink applications and reinstalling the DisplayLink software.

To do so, please follow these steps:

****Please ensure that the Plugable provided USB cable is being used to connect the dock to the system. **

1) Disconnect the dock from the system, and please remove the power cable from the dock, so it turns off completely (this is important, so the unit resets). Please keep it disconnected until the last step
2) Uninstall any and all software with ‘DisplayLink’ in the title that is present from within the Application Folder by moving it into the Trash and Don’t worry if these entries are not present or if the process does not work, move onto the next step
3) Once the Programs has been uninstalled, reboot your computer (even if not prompted to)
4) Download and install the Latest 1.5 DisplayLink software (https://plugable.s3.amazonaws.com/bin/DisplayLink/DisplayLink+Manager+Graphics+Connectivity1.5-EXE.pkg)

Special permissions need to be enabled in macOS*
5) Click on the DisplayLink Manager app icon from the notification area to open the app window. This confirms the software is installed and running properly.

5.5) Select “Launch automatically after logging in” for the software to start automatically every time you log in.
6) Reattach the power cable to the dock first. Once the dock is powered on, reconnect the dock to your system
7) Navigate to your System Preferences to open Security & Privacy
8) Enable “Screen Recording” to allow the DisplayLink Manager app to capture pixels and send them to your USB peripheral:

  • Please select the “Privacy” tab.
  • Navigate to “Screen Recording” in the list on the left.
  • Then tick the “Screen Recording” permission for DisplayLink Manager.
    9) Because the new permission will only be active the next time you start the application, macOS will invite you to** “Quit & Reopen.”** In Catalina 10.15.x, please select “Quit Now.” Please accept.

More info about this process can be found here.

If these steps help, great! If not, I’d like to request some logs from your system to investigate further. Could you please keep the Plugable docking station connected to your system (with the non-working display still attached), then navigate to our PlugDebug tool (https://plugable.com/support/plugdebug) and follow the instructions there?

Please email these results to Support@plugable.com with the subjects as “Ticket 365283”

Thanks for giving us a chance to help!

Omar D.
Plugable Technologies

Hi Omar,
unfortunately, I followed your instruction but it did not work. I sent you the logs files from PlugDebug tool as well as the screenshot showing you that the displaylink is not appearing in screen recording to be authorized.
waiting to hear from you.

Hi Robert,

Thank you for letting us know!

I see that we have received your information in the direct email ticket #365316, and will follow-up there.

Thank you!

Plugable Technologies

my issue is fixed. I had a feeling that not being able to be prompted to authorized DisplayLink into screen recording might have something to do with the fact that my system integrity proctection was disable. Couple days ago I disable system integrity protection to be able to install a patch. Since was struggling with the patch I left it disable. I have decided to enable it back but unfortunately my mac was crashing. I therefore decided to restore my mac with time machine back to the day prior to installing the patch and enabling the system integration protection. After the restore and after insuring that system integration protection is enable, I tried again the procedure above ( the installation of v1.5) and it worked. Now I have my monitor displaying via the docking station. Network, keyboard and mouse working fine. Thanks much for your help.

Hi Robert,

No problem at all, and thank you again for contacting Plugable support!

If you have any other follow-up questions, please feel free to reach out at any time.

Thank you!

Plugable Technologies

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.