Display Blank


#1

Cannot get my additional diplay to work Occasionally flashes then just stays blank


#2

Hello Stephanie,

I am sorry to hear this. You shared log files with us in a separate email and I can see we have an EDID (http://en.wikipedia.org/wiki/Extended…) problem. USB graphics in general work a little different compared to a GPU for example. Without a valid EDID, you will not get the monitor to display. Here are a few things you can try (in succession):

Perform a clean DisplayLink driver installation and bring your graphics drivers up to date:

  1. Disconnect display adapter from the computer
  2. Uninstall DisplayLink Core software from Control Panel -> Programs. Do not worry if this fails, just move onto the next step.
  3. Download and run the DisplayLink cleaner tool -> http://displaylink.com/techsupport_fi…
  4. Once the Cleaner has been run, reboot (do not close the window until you see the message “Cleaning complete. Press ENTER to end.”)
  5. Download and update your Intel graphic chipset driver from here -> https://downloadcenter.intel.com/down… and reboot
  6. Download and update your nVidia GPU driver from here -> http://www.nvidia.com/download/driver…
  7. Now download and run the latest DisplayLink software from our downloads page -> http://www.displaylink.com/support/sl…
  8. Reconnect the display adapter to the computer and test.

If you end up with the same symptoms, try a new or different DVI or VGA cable. If you like, you can pass on the make and model number of the monitor and I can do some further research as well.

Kind regards,
Patric
Plugable Technologies


#3

Hi Stephanie,

Just following up on my last message. Did the problem get resolved?

Kind regards,
Patric
Plugable Technologies


#4