Disks being improperly ejected upon MacBook Pro waking up

Brand new MacBook Pro (15" 2017 model), and my brand new Plugable TBT3-UDV ThunderboltTM 3 Docking Station. Every time my computer goes to sleep, I get an error message upon waking up that my connected USB disks were not ejected correctly.


Hi Phil,

Thanks for posting, and I would be happy to help with your docking station!

Based on your description of the behavior a few quick additional questions for you…

  1. Can you let me know what brand and specific model number USB drive you are connecting to the dock?

  2. Can you let me know which specific USB port in the dock you are connecting the drive to? For example, the USB port on the front of the dock or one of the top two ports on the back (assuming the dock is in the vertical orientation).

I ask because there are two different USB 3.0 Host controllers internally within the TBT3-UDV dock, and an external device’s behavior can potentially change based upon which USB port it is connected.

Thank you,

Plugable Technologies

Hi Bob,

Disk 1 is Western Digital My Book Studio Edition II (4TB, running in 2TB Raid 0 mode)
Disk 2 is Western Digital My Book Essential Edition (640 GB)

They are plugged in the bottom 2 of the 4 USB slots in the back.
The only other thing I have plugged in is the Ethernet cable.

Troubleshooting is fun!!


Hi Phil,

Thanks for getting back, and appreciate the great detail you provided. May I ask you to try connecting both drives to the top two USB 3.0 ports on the back of the dock to see if the behavior changes?

The top two ports are driven by a Fresco USB 3.0 host controller (as is the single port on the front) while the bottom two ports are driven by an Asmedia USB 3.0 host controller, so this may help change the behavior.

Thank you!


Hi Bob,

I hooked both drives to the top USB ports, and the problem appeared to be resolved!

But I thought you deserve more to contemplate, so:

1 - Next, I plugged the 4TB into one of the top (Fresco) ports, and the 640GB into one of the bottom (Asmedia) ports. This setup worked as it should (no improper ejecting).
2 - Just for sanity, I plugged both back into the original configuration (both into the Asmedia ports). Original problem came back, with improper ejecting.
3 - I brought in another drive (3TB WD My Book Live) and plugged it into the Fresco port alongside the 4TB drive. This setup, with all 3 drives, worked as it was supposed to.
4 - I moved the new drive from the Fresco to the Asmedia port (alongside the 640GB). This setup worked as it was supposed to.

So it looks like the TBT3-UDV works fine, as long as at least 1 device is plugged into a Fresco port.

This was an awesome experiment!

Hi Phil,

Thanks for getting back with the update, and again I appreciate very much the detail you provided and the additional testing you performed. I am glad to hear that everything is working as expected in the new configuration, and the results you provided will be very useful as we help others in the future.

Please let us know if anything changes in the future, and please have a good weekend!