Disappearing Device (nothing up my sleeve)


#1

I’m back. It has happened again, several times. The problem appears, or should I say the device disappears, when Windows does an update and reboots. The software/device drivers are still there yet they don’t respond to anything. In Device Manager, the UGA-2k-A listing disappears. I can’t reinstall it until I uninstall all the drivers. It happens with both vers. 5.3 and 5.4.

I have tried all permutations of unplugging/replugging in adapter, USB and HDMI connections with and without a reboot. Nothing will reactive the device until I uninstall the drivers and reinstall.

The computer is normally put in Sleep mode. If I manually shut it down and restart there doesn’t seem to be any issues.


#2

Hi Lutz,

I’m sorry this problem is still haunting your machine. I hope we’re able to find the right magic to resolve it.

Just from the symptoms, it sounds like the Windows Vista USB stack is seeing some kind of error on return from sleep and then not allowing this device to enumerate again (until a reboot or reinstall). I suspect a driver/sw problem that’s timing related, triggered by return from sleep.

Have you had the chance to run the latest displaylink 5.5 drivers? They are worth trying for two reasons: some improvement in return on sleep behavior, and also because they uninstall more cleanly. In your case, there’s a chance a clean uninstall could help.

So would you be willing to install 5.5, uninstall, and then install again - and see whether the sleep issue is resolved?

If this doesn’t work, we can dig deeper with debug logs. If you can run DisplayLink’s tool athttp://www.displaylink.com/support/ti… and email the .zip file it creates to support@plugable.com, we’ll be able to see more about what might be going wrong.

If you have a powered USB hub available, other thing worth trying is connecting the adapter through that. Both the different timing and isolation of power issues might work some magic with the sleep problem, if we’re lucky.

If neither of these steps help, DisplayLink has been working on sleep issues, so future driver updates may contain a solution. But we wouldn’t want to have you waiting with a broken steup for an unknown period of time, so just email your amazon order # to support@plugable.com, and we’d be happy to process a return if waiting like this isn’t workable - we totally understand.

Thanks for your help and patience working to a solution here!
Bernie


#3

Another quick thing to check - “sleep” has two meanings on Windows. “standby” where the system is still running, but CPU and all devices set to lowest power but system state is kept in RAM, or “hibernate” where memory is also saved to disk, and the system is fully powered down.

From the windows control panel, would you be able to try setting the hibernate and standby times to have the system drop directly into hibernate (bypass standby), and see if that is a possible workaround?

Thanks again!
Bernie


#4

I’ll try some of your suggestions as soon as get home from work. I have a nvidia video driver that has its own issues with Windows Vista 64. It sometimes returns from hibernate and tries to readjust the video to a resolution that my TV doesn’t support. It doesn’t occur in standby. But for you I’ll try it.


#5

I installed 5.5 and it was running fine. Then I set Vista to hibernate. Unfortunately I had to do a reboot and Lo and Behold, the device is gone from list of available displays in the Nvidia control panel. It does appear as working as a USB display in Device Manager. The popup menu doesn’t do anything and the “off” position is opted and can’t be changed.


#6

Hi Lutz,

One important note - always configure the USB displays through either Windows’ built-in display control panel or DisplayLink’s tray applet. Using any of the control panels or applets from nVidia, ATI, etc. won’t work (or won’t work reliably). I couldn’t tell for sure which were being used.

Assuming the problem is happening via Windows’ control panel, unfortunately this may be a more complicated conflict between the DisplayLink drivers and the nVidia drivers on this system. DisplayLink’s drivers have dependencies on both the OS and the GPU’s drivers.

If you’re willing, could you run the DisplayLink debug tool to gather the logs on the system: http://www.displaylink.com/support/ti…

And email the resulting .zip file (placed on your desktop) to support@plugable.com – that will give us a lot more details about what’s happening behind the scenes.

I’m sorry simple things haven’t solved this one. There’s still a good chance that the logs will reveal the problem, though.

Thank you for your patience in working through this!
Bernie


#7

Hi Lutz,

Thanks so much for emailing us email the output of the DisplayLink debug tool (which gathers the DisplayLink related log files).

Looking at what was gathered from \Program Files\DisplayLink Core Software\Debug

It appears DisplayLinkManager.exe (the main user mode component of the DisplayLink drivers) has crashed and left behind some .dmp files in this directory.

Looking at DisplayLinkManager.log, it appears to be an assert that’s happening during power transitions. The failed assert is (itr->target) is unexpectedly null at line 189 in file .\DDCManager.cpp for build 5.5.27797.0.

This doesn’t mean anything to us, but could help pinpoint things for the driver developers at DisplayLink.

As you said before, the system is running Vista 64 SP2. AMD Athlon dual-core 5050e. nVidia GeForce 7025/ nForce 630a GPU.

So unfortunately this appears to be a driver bug that would happen with any DisplayLink-based device. And since you’ve tested 5.3, 5.4, and 5.5, with similar problems - it’s probably a situation or series of events at power time related to this AMD/nVidia machine configuration that the DisplayLink drivers never expect to happen. So we need a fix in the drivers.

What we’re going to do is report this problem to DisplayLink, send them your complete set of logs, and follow up on it until we think we have a driver version which is expected to have the problem resolved.

But this requires waiting for new driver versions - and this can take some time, unfortunately.

So we have two choices in the meantime:

* We don’t want you stuck with hardware/driver that isn’t working properly, so returns should be as easy as possible. Visit http://www.amazon.com/gp/css/returns/… and if you’re beyond the period Amazon will handle returns, just email your Amazon order # to support@plugable.com and we’ll refund directly
* The other choice is to turn off standby/hibernate on this machine so the problem isn’t triggered, until we have the driver fix.

Again, my apologies for this problem and thank you for sticking with us to where we have good evidence of what the underlying problem is.

Either path you take, we totally understand. Just let us know.

Thank you!
Bernie


#8

Hi Lutz - A quick update. DisplayLink has reproduced this problem in their labs, and they believe they have a fix coming. It is scheduled to arrive with their next release (version 5.6), which is expected at the end of December/early January.

Thanks so much for reporting this issue! Your report and your logs were instrumental in getting this fixed!


#9

I am having the same problem as Lutz. I have an Nvidia Quadro NVS160 Driver 8.17.12.5896 on a Win7x64 Dell notebook. When my monitor go into power save mode (per settings in Power Options) and the display powers off (notebook NOT in standby or hibernate) they fail to return on wake (moving the mouse or touch keyboard). I have installed both version 5.5 and now the 5.6 beta with same results.

My work around at the moment is to disable my monitors from powering off under Power Options in Control Panel.

Please fix…

-Walter


#10

Hi Walter,

Very sorry you’re having the same problem, but thank you for good details on what you’re seeing - it helps to get these extra datapoints.

We would definitely like to track this down. There appears to be more than one nVidia/DisplayLink return-from-sleep problem that DisplayLink is working on. If you would be able to run the DisplayLink debug tool (instructions above on the web for this issue), and email to support@plugable.com, we could look at the details to see if the cause is the same as Lutz (the assert visible in the logs).

Again, our apologies, and we do want to track this down and give DislpayLink the the information and impetus to fix in a driver update.

Thank you!
Bernie


#11

Hi Guys. So far so good. I uninstalled ver. 5.5 and installed 5.6 beta. Windows had an update available last night and I let it update and reboot and the device drivers are visible and active when clicked. I’ll keep you posted if things change.


#12

Bernie,

I ran the DisplayLink support tool and sent the support file. I had to remove the memory.dmp file because it made the zip to large to email. The memory.dmp file alone is 123 MB compressed. If you have a FTP site I would be happy to upload.

Thanks,
-Walter


#13

Hi Walter - Thank you! We got it - the memory.dmp file isn’t important, so great to leave it out to shrink the size. We’ll be looking at the logs these week, and will post anything that jumps out.

What we’re suspecting is you’re experiencing the same symptoms as Lutz (problem with resume from low power, only on certain nVidia systems) but that the root cause is different than what Lutz was hitting (Lutz’s was an assert signaling that the displaylink driver hitting a situation it had never planned for; we’ll see in your logs whether that assert or other clues are present).

Thanks for sending in those logs, and thanks for your patience!
Bernie


#14

Thanks to Walter emailing the logs, we were able to confirm (unfortunately) that his issue is different from Lutz’s, so it makes sense that it is not fixed in version 5.6

The cause of Walter’s issue didn’t jump out for us, so we’ve created a ticket for Walter’s case with DisplayLink (ticket #2011011742000046), and will follow-up on that. If anyone else has a similar sounding issue that is not fixed by 5.6, we would like to hear about it (we should start a new topic on the support site here).

And in the interim, the short-term workaround is to set monitors to not sleep, until the whole system does.

We thank Walter for his info and patience while we work on this issue.

Thanks!
Bernie


#15

Hi Lutz,

DisplayLink has released a beta of their 5.6 version, which they believe fixes this issue. Their work on this was triggered by your report and debug information that we forwarded.

Here’s the link for the 5.6 beta driver: http://displaylink.org/forum/showthre…

Can you test and confirm if that’s the case for you?

Thanks again!
Bernie


#16