Digital Microscope with USB 3.1 port


#1

When I start the Plugable Digital VIewer with the Digital Microscope plugged into a front panel USB 3.1 port, the program gives me an error and says the program has stopped working. Unplugging the microscope and the program works fine and defaults to my webcam. Any way to get this working on a 3.1 port?

Thanks,
Don


#2

Thanks for asking!

The behavior shouldn’t be any different on any USB port, and you shouldn’t be seeing an error regardless of what type of port the microscope is attached to.

Have you tried using the microscope in different ports to see if the issue persists?


#3

HI Sam,

Thanks for the reply. This is a new computer build I’m trying this on and haven’t had any USB problems with any other devices. (MSI 990-FXA mobo) I tried the microscope on USB 2.0 ports on the back panel and got the same problem. Device works fine, tried it on my Dell laptop running Linux Mint 18 and didn’t have any problems. I think the problem is with my system. I’ll see if MSI has any new drivers for this motherboard.

Not too worried about it because I’m not planning on using the microscope on this computer. It’s headed for my workshop for inspection duty.

Thanks,
Don


#4

Well at least the device is working as intended on another machine. It’s odd that it wouldn’t work even on USB 2.0 ports on your new mobo.

Updating host controller drivers may very well help with this. Looking into the specs of your board, it looks like MSI used a crazy combination of three different USB host controllers with a built-in hub, so the USB interactions here might be a little strange. You might try playing USB port bingo a bit to see if the microscope will work on one of the ports.

I’d recommend against messing with the drivers on this system if you aren’t planning on using the microscope with it. This setup could prove to be a little fragile.

If you want to pursue this I suggest contacting me at support@plugable.com so I can dig a little deeper!


#5