Digital Camera not working

Just received the Pluggable USB 2.0 Digital Microscope and cannot get it to work.

Windows 10 Pro. Known good usb ports (4 - 2.0 and 2 - 3.0)
Download and install drivers from your website for windows.
Connect camera.
Run app.
“No camera is detected, please connect your camera.” keeps appearing.
Windows devices shows a camera connected (i have no other cameras).
Same problem.

Uninstalled software. Reinstalled as Admin.
Same problem. Reboot, Same problem.

Windows Devices does show a ‘USB Microscope’
Windows camera app shows NO cameras available.

When i unplug the camera, your app pops up the “No camera is detected, please connect your camera.”

I have also allowed camera use under the Windows Privacy settings.
In your app, the devices list is empty.
I have not seen any leds light at all.

Please advise.
Thank you

Thanks for getting in touch!

Have you tried using the built-in Windows Camera app just to rule out Digital Viewer as a culprit?

Also, do you happen to have Oculus software installed?

Thanks for the reply!

The windows camera app shows no cameras available.

I do have Oculus software installed but do not own an Oculus. I have a Vive and use ReVive to run Oculus games.

Under Task Manager - Services:
OVRLibraryService - ‘Oculus VR Library Service’ - Stopped
OVRService - ‘Oculus VR Runtime Service’ - Stopped

I stopped the Oculus services from running because whenever i play certain VR games it likes to pop up from time to time.

3 days and only 1 response for a product you sold is unacceptable.

Thanks for confirming that! I’m sorry we weren’t able to help quicker, we have limited support staff on the weekends.

If Oculus software is installed on the computer, the microscope will not work. The microscope uses the same chipset as the Oculus positional sensors, and Oculus made the frustrating decision to create proprietary drivers for the sensors that make the system think it isn’t a UVC device. The only guaranteed way to fix this is to remove all Oculus software and drivers and reinstall the microscope driver, or in some cases to perform the below steps:

  1. Disconnect the Oculus Rift sensors and cameras.

  2. Connect the Plugable USB Digital Microscope.

  3. Open the Device Manager in Windows. This can be done several ways, if you’re uncertain how to access Device Manager perform these steps:

  • Press the Windows key and R (Win + R).

  • In the window that pops up, type “devmgmt.msc”, then click OK.

  • Look for the microscope. It will likely be listed as a Rift sensor, under ‘Oculus VR Devices’. If you’re not certain if you found it, disconnect the microscope and the entry should disappear. Reconnect the microscope and the entry should come back, that’s how we’ll know for certain we’re looking at the correct device.

  • Once we’ve found the microscope, right click on it. Choose ‘Update Driver’ > ‘Browse My Computer For Driver Software’ > ‘Let Me Pick From A List Of Device Drivers On My Computer’, then look for ‘USB Video Device’, then click next to complete the install.

NOTE: After completing these steps, Windows will still name the microscope as ‘Rift Sensor’. To confirm these steps worked, look for an entry for Rift Sensor under Imaging Devices or Cameras (if the steps did not work it will be listed under Oculus VR Devices still). The user will need to select ‘Rift DK2 Sensor’ to use the microscope in Plugable Digital Viewer or other applications.

Let me know if that does the trick!

YES! It even renamed it as ‘USB Microscope’
Updating the driver as stated above worked.

I apologize for losing my composure.
Thank you Sam.

You may want to see if this can be posted onto the Amazon site for this product. Seems like other people are having issues.

Glad that did the trick!

We do have this information posted on our product page under the FAQ section:…

Unfortunately there’s no way for us to really engage on the Amazon listing support-wise, or we’d certainly put troubleshooting tips there.

Let us know if you run into any other issues, we’re always happy to help!