Device not recognized after Sonoma update

I have a Macbook M2 pro and the USBC-E1000 that I have been using together for several months. The device worked perfectly until I upgrade my OS to Sonoma yesterday. Ever since then, I have not been able to get my Macbook to recognize the adapter.

I have been able to get my Macbook to recognize another Plugable device I have (one of the older thunderbolt docking stations), so the issue seems to be this adapter.

I have also noticed that when I have it plugged in, my Macbook occasionally freezes and reboots without prompting, which is the first time this has happened to me on my Macbook.

Any thoughts on how I can debug or troubleshoot?


Hi AJax2012,

Thank you for contacting us and welcome to our forums! As for troubleshooting there are a few steps we can take like deleting this network adapter in the System Settings app and a further step we can take is to fully reset the Network Configuration.

We have written a knowledge base article on how to go about these two troubleshooting steps, if you could please visit this guide.

My Plugable product with wired Ethernet is no longer working on macOS. What can I do?

If these freezing and reboot issues continue to come up please contact us directly through our support page and reference ticket #416224. We can look into other support options such as replacement through our device’s warranty.

I hope the troubleshooting works out!


Plugable Technologies

1 Like


I updated to Sonoma and am experiencing the same issue with my new UD-6950PDZ display. It worked well for a few moments and then I updated my Macbook and it did not work after.

Is there an update on the drivers coming? Or, can someone troubleshoot? This is a replacement station after the first had a similar issue prior to the update.

Thank you

1 Like

Thanks for replying! Unfortunately, the instructions in the link don’t seem to work… Even deleting the config file in Preferences didn’t seem to reset the network configuration. I’m not sure, but the instructions also seem a bit out of date, since the GUI also seems to be a bit different now (though I could still follow along fairly easily).

I was able to manually delete each of the entries in the network configuration tab of the System Preferences, but when I went to re-add it manually, it didn’t seem to do anything.

I can take a look at the ticket tomorrow; thank you again!

UPDATE: I actually found the 5-IN-1 HUB and decided to get that instead! I’ve been wanting an easier way to plug in USB type A devices, so that works out really well.

UPDATE 2: 5-IN-1 HUB works great. If anyone else is having trouble with the USBC-E1000 and is looking for something affordable that uses USB 3.0 type A, I’d recommend this.

Hi AJax2012,

If you would still like to further troubleshoot the issues with the USBC-E1000 at this point I’d suggest reaching out to us directly.

We can take additional steps like collecting a set of log files from your system to better determine the next step for support and finding the root cause of this failure with the adapter.

The best way to reach us is through our support page here:

Pleas reference ticket #416224 in your email to us.


Plugable Technologies

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.