Dell XPS 15 (9550) UD-CA1 Disconnecting HDMI repeatedly


#1

I’m trying out a UD-CA1 dock, hooked up to Dell XPS 9550 (Nvidia graphics) and a Dell 24" 2560x1440 display.

When attaching just the USB-C cable (the OEM one shipped with the Plugable dock) and the HDMI cable to the monitor, the connection seems “flaky”. It can’t maintain a connection for more than a few seconds. The same HDMI cable can be used directly to the machine without any problems. All drivers from Dell (include BIOS updates) are up to date.

Under Windows 10, I get an error occasionally indicating Windows has encountered an error with an attached USB device.

I’ve also tried the dock under Ubuntu 16.10, and that seems to have similar results. I get a full desktop (expanded, not mirrored) for a second or two before the screens (both internal and external) go black. Then they come on for a second again and then go back off. In the kern.log I get this error thousands of times:

usb 3-1.1.1: 2:1: usb_set_interface failed (-19)

Power deliver to the computer does seem to work, but beyond that I can’t get much to function. Even with no items plugged into the dock, the computer seems to slow down substantially, with a cursor delay and slow window refreshes.

I’ve previously used both the Dell TB15 and subsequent TB16. Both of those docks were also highly problematic, though it was mostly the audio and network that dropped out occasionally. The HDMI connection had always been solid.


#2

Also after reading about wifi power output being a problem in some scenarios with this model computer, I’ve tried putting it into airplane mode (disabled wifi and Bluetooth), but that did not have any change in behavior.


#3

Hello Nate, thanks for posting. I am sorry to hear of this behavior when using our UD-CA1 dock and I will be happy to help.

Thank you for the description of the behavior you are seeing and letting us know the steps taken to troubleshoot already. Based off of the fact that you have already updated the system’s BIOS, Thunderbolt 3 drivers, and video drivers we will want to send you a pre-tested replacement dock to make sure that the hardware is functioning properly. I will send you a separate email to your email address tied to your forum account to begin this process and arrange the replacement accordingly.

Thank you,

David W.
Plugable Technologies
www.plugable.com/support


#4

Thanks David, I’ll continue with your support via email and post a follow-up. I would like to try this dock again, as it seems like this dock meets my needs perfectly if it were fully functioning.


#5

I am having the exact same issue. Though, I did not test with Linux.

System: XPS 15 9550 Intel/Nvidia 960 connected via supplied USB-C cable
Monitor: Dell U2415 connected via HDMI


#6

JP, they’re sending me a replacement dock. I’ll let you know if the second one works better than the original.


#7

Thanks!


#8

Well the new dock arrived just hours after my last update (thanks Plugable!)

The new dock at first appeared to work perfectly. I was curious if I could determine the “broken” piece of the setup and tried the old dock with new cable, new dock with old cable etc. Everything worked both with the old and new dock.

Then I realized the difference from when I tried a few days ago: I had left my AC adapter plugged in. So the dock was not responsible for power delivery.

Unplugging the AC adapter and letting the dock handle power, I immediately ran into the same problem with the new dock (old dock still did it too of course). The external monitor flickered on and off, USB disconnected, and the laptop became sluggish to respond to any normal input via trackpad or internal keyboard.

While the laptop AC adapter is unplugged, the laptop appears to charge when running exclusively off power delivery, and plugging anything into the laptop everything still works fine. But attempting to use any functionality of the dock while the laptop is using power delivery fails just about everything.

So long story short: The dock works great as long as you don’t use power delivery (i.e. plug in both the normal laptop AC adapter and the dock). Unfortunately, the power delivery was the main reason for getting this dock over other options. The XPS 9550 might just draw too much power for this dock to handle.


#9

I tried that solution, and it also works for me when I also have it plugged into a power supply. Plugable, is there any other work-around?

Nate, thanks for keeping me in the loop!


#10

I solved similar issue ‘not enough power’ by setting Wifi power to 75%.


#11

@Nate, thank you very much for the reply, Nate! What you describe is what we have seen on 9550 XPS 15 systems with Intel GPUs. We have the power deliver portion listed as Not compatible on our compatibility chart here --> http://plugable.com/products/ud-ca1/. So I am not sure why you experience the same with your system with an Nvidia GPU.

@JP, your experience may vary, but lowering the Wifi Power setting to 75% or lower may help, as John describes above. We also have a in depth blog post here --> http://plugable.com/2016/06/30/invest… that outlines steps that can be taken to improve performance issues that we have seen on the Dell Thunderbolt 3 systems.

Thank you,

David W.
Plugable Technologies
www.plugable.com/support


#12

David, thank you for your reply. My wifi was already at 75%, and setting airplane mode will not work for me. If there is no other solution, I will have to initiate a return with Amazon. Can anyone think of anything else?


#13

Thanks David, I consulted the page you linked to in my research, which is why I assumed it would work. Given the findings here and with JP’s confirmation, I think the compatibility chart should be updated to reflect that Power Delivery is NOT compatible with the XPS 9550 with Nvidia/Intel graphics.

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1623131/Selection_004_inline.png?1500346805)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1623131/Selection_004.png?1500346805)

Honestly I was a bit skeptical it would work, considering the power drain required by this laptop. And I don’t see why the model that requires less power would not be compatible while the higher-end model would be.


#14

I’ll also add that reducing WiFi power (or disabling it entirely) has no effect on the stability of the dock if the laptop is receiving power through the Thunderbolt/USB port.


#15

I agree with Nate on all points, including the necessity of updating that chart. I wish it could work, but it just won’t, it seems. I have initiated a return through Amazon, which Pluggable should have on hand to authorize.


#16

Hi I have just received this unit and and having the same issue.
I have to plug in the power or I have a flickering monitor. I also have the xps9550 Intel+ Nvidia GPU

I also have a problem with my external mouse and keyboard. It’ll work fine and then all of a sudden the mouse will start sticking and then keyboard will will stop responding then type out loads of garbage all at once.

Really want this unit to work but starting to struggle with it.

Are there firmware updates or anything I can try?


#17

@Macguffin, thanks for posting and sorry to hear of these issues. There are no firmware updates that we can preform but I would be able to investigate. Please contact our direct support email address at support@plugable.com at your convenience and we can go from there.


#18

Thanks David sent you guys an email earlier (Request #193244).

Look forward to hearing from you.


#19

This is exactly the behaviour that I found with my Dell 9350. External power is/was the only remedy.


#20