Dell E2010H detecting resolution as 1440x900 instead of 1600x900. System shows 1600x900 though.


#1

Dell E2010H detecting resolution as 1440x900 instead of 1600x900. The windows display settings and displaylink software show the second monitor as 1600x900. However the OSD on the dell shows 1440x900 and the desktop appears slightly blurry. I have tried installing the latest drivers and software. The graphics chipset is Intel G45. I also have tried rebooting, and changing resolutions down and back up, also trying other USB ports.

The model I have is a Plugable-USB-VGA-165
The OS is Windows 7 Home


#2

Hello Jeffery,

Sorry to hear this. We might be dealing with EDID (https://en.wikipedia.org/wiki/Extende…) corruption. Without a valid EDID you will either not get a display at all or a corrupted one. Try a clean DisplayLink driver by doing the following:

  1. Disconnect display adapter from the computer
  2. Uninstall DisplayLink Core software from Control Panel -> Programs. Do not worry if this fails, just move onto the next step.
  3. Download and run the DisplayLink cleaner tool -> http://displaylink.com/support/sla.ph…
  4. Once the Cleaner has been run, reboot (do not close the window until you see the message “Cleaning complete. Press ENTER to end.”)
  5. Now download and run the latest DisplayLink software from our downloads page -> http://www.displaylink.com/downloads/…
  6. Reconnect the display adapter to the computer and test.

If we end up with the same result try a different or new VGA cable. An update for the Intel G45 might also be needed (https://downloadcenter.intel.com/prod…). This chipset in computer terms is also old (Intel has also stopped support) and there could be the slight possibility that we cannot solve this problem due to discontinued support.

Kind regards,
Patric
Plugable Technologies


#3