Dell 4K S2817QR monitor blinks if any USB device also plugged into UD-5900


#1

The computer is a Surface Pro2 running Windows 8.1 with the latest Pluggable display drivers. I replaced my monitor with a new 4K monitor from Dell (S2817QR). To make that work, also replaced my Pluggable UD-3900 with a UD-5900.

The UD-5900 sorta works. It will drive the monitor via HDMI if I don’t plug any USB devices directly into the UD-5900. If I plug any non USB 3 devices into the UD-5900, the monitor will go dark, but the USB devices will work. I was able to plug the monitor’s USB3 cord into the UD-5900 and then use the monitor as a hub for the devices.

Have I got a defective UD-5900 are is it working as designed?


#2

Hi David,

Thanks for contacting us, and please accept my apologies for the long delay in our reply (we had a glitch with our web forum that did not notify us of some new posts).

The behavior you describe is definitely not normal, so our first step is to get more information. If you would, please send the output of our diagnostic utility PlugDebug --> http://plugable.com/support/plugdebug to support@plugable.com with ‘Ticket 168267’ in the subject line so we can match things up. This will allow us to examine some log files from your system to help determine the next steps. ** Please also include your Amazon Order ID number for the dock purchase (don’t post that here in the public forum) **

Again, please accept my apologies for the delay in our reply and thank you for your patience!

Bob
Plugable Technologies
www.plugable.com/support


#3