Computer locks up over a few hours to days if I have the 10 Port USB hub connected


#1

I’m noticing that if I have my 10 port plugable hub connected, my machine will not open programs and also task manager will not open .

I’ve disconnected the hub and so far so good. I have most of the same devices connected directly to the computer that I once had connected to the hub.


#2

Hi Nick,

Thanks for also submitting this public post.

A USB hub itself doesn’t have any 3rd party software (it’s controlled directly by Microsoft’s USB stack) – unfortunately or fortunately, there is nothing that could cause problems opening programs after some time using the system. Devices connected to the hub may have their own software, though.

We can’t tell, but it’s sounds like either a resource leak issue (e.g. after running for several days, some programs on the system may be leaving behind open windows) or a virus (but that is easy to fear, and difficult to tell for sure).

Here is some more information from others hitting the window limit issue on XP: http://www.annoyances.org/exec/forum/…

Here is Microsoft info on troubleshooting task manager issues:
http://windows.microsoft.com/en-us/wi…

We would expect that if you have all the same devices connected, you should get the same behavior in this area with or without any USB hub. For a problem that only happens every few days (or even weeks), that may be difficult to determine without running for a while.

If you don’t find that’s the case, the area we’d look in next is probably power management – because it involves all the devices and drivers on bus, it’s probably the one area where XP’s USB stack (or the drivers of attached devices) might have subtle enough behaviors that the presence of a USB hub could make a difference. But we haven’t directly heard of anything like this before, and couldn’t find any evidence googling around for it.

Thanks for updating if you get any more datapoints. We want to help any way we can!

Thanks and best wishes,
Bernie


#3

Thanks Bernie, I appreciate the professional response. I’ll keep the thread up to date. So far I’ve had the machine up and running most of today without a hitch. I don’t know if maybe there’s an electrical issue or a bad cable maybe… who knows but we’ll see as time runs on. So far no trouble after the hub has been disconnected. I’ve had this problem for about 6-9 months now so I’ll try it without the hub and then plug it back in and see what happens.


#4

So far no issues (Still working perfectly with the hub unplugged). I will try just the hub and maybe the mouse and keyboard after a few more days and see what happens.


#5

Hi Nick - Thanks for the updates! And thanks for taking this time to isolate down the issue!


#6

Still not having any issues. I don’t know if maybe an electrical issue could possibly bother Windows and cause this. Not sure. But I’ll leave it a couple more days and then plug it in and try running the hub once more.


#7

Hi Nick - We’d also like to send you a 2nd unit, just so you have it on hand to help with isolating things down – to rule in or out anything at a hardware level.

We’ll get that on its way to you. Thanks again for the updates!


#8

I appreciate that Bernie. I’ll check it for a few more days first. I’ve had trouble for a long time (around the time of purchase I believe) and assumed it was a virus but after checking it with all sorts of different programs and coming up with no infections and even re-installing Windows, I figured (with the prompting of a spyware/virus forum) I’d start testing hardware pieces.

But seriously, I appreciate the offer there. I’ll watch another couple days, then try again with only the USB hub and mouse/keyboard and see.

I’ve had things surprise me in the past and I wouldn’t want a new hub on Plugable unless we really know that’s the problem.

I definitely appreciate the support.


#9

Interesting, I just shut down, plugged the hub in, connected only the devices I’ve been using in but now into the hub instead of the computer. I only have the following connected as I did earlier (bare bones):
-Keyboard
-Mouse
-USB Sound Card

None of it worked initially because Windows had to install the new device software for the hub. Why would this be since the hub isn’t a new device (just used it a few days back before the experiment)? Also all the individual devices had to be re-installed.

I ended up having to plug the mouse and keyboard into the computer and restart to be able to go through the install new hardware steps for the hub since they weren’t working in the hub (new device). Then after the hub was installed I unplugged them from the computer and back into the hub.

I wonder why this would be?

Beyond that, we’ll see how it runs over the next few days. If it gives a problem, I’ll try a new cable to the hub and see if that fixes it.


#10

So far it’s working. USB hub connected and no trouble (1 day of operating so far).


#11

Hi Nick - Thanks so much for the updates! It’s great to hear that the hub is working fine with keyboard, mouse, and USB sound card.

Do you suspect that one of the other USB devices (and/or their drivers) could have been playing a part in the earlier troubles? Let us know if we can provide any info or help.

By the way - devices without unique serial numbers (like keyboards and mice) are re-installed by Windows when they’re plugged into a new USB port, which might be why you saw those driver install messages…

Thanks again!
Bernie


#12

That’s entirely possible. I will try plugging additional things in one at a time and see what happens.

So far since re-plugging the hub I’ve been up 2 days now with no issues. So it seems whatever it was, was USB related.


#13