comes and goes


#1

Plugable UD-160-A USB 2.0 Universal Docking Station

device drivers seem to load and unload and display goes back and forth between laptop and external monitor
and Plugable device appears and disappears - I have unplugged all of my devices and still does same thing

this is an acer aspire 5750-9668 laptop with windows 7 home premium 64 bit

it has some power mgmt software for power on the usb 3.0 ports which i disabled. this did not help.

i downloaded the latest 6.1 beta software and have the same symptom


#2

Hi Mike,

Thanks for posting! I am sorry to know that you are having trouble with the Plugable UD-160-A USB 2.0 Universal Docking Station.

Do you see this disconnects on both the USB 2.0 ports on your Acer Aspire 5750-9668 laptop?

Do you have access to another system ? If yes, could you plug the Plugable UD-160-A USB 2.0 Universal Docking Station to it and let us know if you see the disconnects on it too?

Once you post back with this information, we will figure out the next steps.

Thanks for your patience!

Regards,
Roze


#3

I want to thank Roze and Bernie Thompson for sending a tested replacement unit which resolved the issue!

Thanks again,

Mike


#4

Thanks, Mike! We’re glad to have you up and running!


#5

I am having the same problem with my UT-160-A device since I purchased it a couple of weeks ago. I’m using it with a Lenovo x220 Tablet and a I-Inc monitor at 1920x1080 res. I thought the problem was created when the monitor was just turned on, but it is now occurring intermittently throughout the day.


#6

Get in touch with support. They will help. My unit was replaced and the new one works perfectly.


#7

Hi David - It sounds like the UD-160-A is disconnecting/reconnecting. Just shoot us a quick email at support@plugable.com. With a few questions, we’ll be able to figure out if it’s a hardware or software problem, and get you fixed up. Sorry for the frustration - thanks for your patience!


#8