Chromebook c434t doesnt recognize usb3-e1000

no lights on device, usb port works, tried rebooting. network is home, wired to router. tried a windows 7 pc, it see’s the adapter but cant find driver…no lights here either.


Thanks for reaching out to us! I am sorry for the trouble here, and I’d be glad to help. There are a few things happening here, so let’s focus on the Chromebook first. We’ve seen good success with our USB 3.0 Gigabit adapter on Chromebooks, but there are a few things we should check to see if we can get you online.

First, you’ll want to make sure that the Chromebook has the latest version of the operating system installed.

  • You can update the computer by going into Settings > About Chrome OS > Check for updates.
  • If an update is available, please let it run, and then restart the computer.

Next, Chromebooks without Ethernet ports default to the built in WiFi adapter, so we will want to turn WiFi off temporarily at least. ​​​

  • You can do so by going into Settings > Network, and turn WiFi Off. (Not all Chromebooks will necessarily require WiFi turned off for Ethernet to work, but its a best practice)



After turning the WiFi connection off, please plug the adapter back in and let’s check the connection. If you would, please give this a try, and let me know what happens. I hope this helps!

Thank you,

Plugable Support

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.