Cant enable chroma sampling 4:4:4 with Plugable DisplayPort to HDMI Active Adapter


#1

Hi
i have a question about Plugable DisplayPort to HDMI Active Adapter. i have connected my amd 390x to my lg tv 55UJ634V with this adapter and a 5 meter hdmi2.0 cable. it works with 4k@60hz 8bit but there is no option in the amd settings to choose chroma sampling. (the option is there when i use the hdmi cable without the adaptor). the tv has the advanced color settings on all hdmi ports. any thoughts on what i could do to enable 4:4:4?


#2

Hi Kiri,

Thank you for reaching out to us, I am sorry this is not working as expected.

When the Chroma Sub-sampling settings are not available in the Radeon software, the settings are being automatically negotiated by the system, DisplayPort to HDMI adapter, and monitor. This auto negotiation is based on the features requested as well as the quality of the signal. I recommend starting by testing with a shorter cable, no longer than two meters to eliminate problems often seen with longer cables and signal loss preventing 4:4:4 sub-sampling. To expand on this, the DisplayPort has to not only power the DisplayPort to HDMI adapter but also the HDMI signal along the cable, without the additional conversion to HDMI the 5m cable may work fine, however with some power used to convert the signal to HDMI the cable is susceptible to more interference and the resistance along the length of the cable can cause the automatic negotiation to increase compression.

Please let me know if the shorter HDMI cable works, if there is no change we can look into settings on the TV that may be affecting the quality of the display.

Thank you,

Pat
Plugable Technologies
www.plugable.com/support


#3

Hey, I really appreciate the fast and comprehensive response! :slight_smile: What you said makes perfect sense to me so I will try the 2m hdmi cable. I just thought I should let you know that I wont be able to test it until tomorrow. Until then I have a question, is there a way for me to check which Chroma Sub-sampling settings are being used at any given moment? I mean since the setting is not available in the Radeon software I have no way of knowing which setting is being used. For all I know 4:4:4 might already be in use!?
thanks again for the help, I will give feedback about the shorter cable tomorrow.


#4

Hi Kiri,

Unfortunately the Chroma Subsample setting is not easy to check, however it can be visualized easily on the monitor itself. This website ( https://www.rtings.com/tv/learn/chrom… ) has a great test image that should be crisp and clear at 100% size ( with desktop scaling set to 100% ). If the subsampling is set to 4:2:2 or 4:2:0 then the text will be fuzzy, the blue/red lines at the bottom may be completely unreadable.

Please let me know how this works out!

Pat
Plugable Technologies
www.plugable.com/support


#5

ok it took me a few days but I managed to test all of the above suggestions. first I did the chroma test and I can easily read the red/blue lines at the end but I cant exacly describe them as clear, they are definitely a bit fuzzy. I also got a 2m hdmi2.0 cable and the result is exactly the same with the 5m cable! still no option to select Chroma Subsample in radeon settings. :frowning: from what I understand these settings are affected by the bandwidth tha my cable can support but the weird thing is that with the adapter I have a lot more bandwith than I do with the hdmi cable alone but I still get less features available! I am attaching printscreens of my radeon setting with the hdmi alone and then with the adaptor. with the hdmi I can get 4k rgb4:4:4 8bit and hdr enabled in windows settings but all this at 30hz. with the adapter (which amd registers as having more bandwidth) I get 4k no option to select chroma and no hdr but all this at 60hz. I don’t get it… I even tried setting it to 4k@30hz and I still don’t get the chroma options. !](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1728604/hdmi1_inline.PNG?1525517029)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1728604/hdmi1.PNG?1525517029) !](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1728605/hdmispecs_inline.PNG?1525517060)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1728605/hdmispecs.PNG?1525517060) !](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1728606/dpadapter_inline.PNG?1525517084)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1728606/dpadapter.PNG?1525517084) !](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1728607/dpspecs_inline.PNG?1525517144)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1728607/dpspecs.PNG?1525517144)


#6

Hi Kiri,

Thank you for the additional details! With the red/blue lines being readable, your monitor is at Chroma Sub-Sampling of 4:4:4 or pixel-perfect transmission!

The lack of sub-sampling options indicates the Radeon software is correctly identifying the connection as DisplayPort output and is not attempting to compress the data, which is a good thing in this case as it preserves the image quality. To expand on this, HDMI was designed to be used with compressed video sources such as DVD which had already been sub-sampled down to 4:2:2 or 4:2:0 so applying the Chroma Sub-sampling does not reduce the picture quality, however DisplayPort was designed to send pixel perfect data to the monitor, the Radeon software may not allow for Chroma Sub-sampling on the DisplayPort for the optimal picture quality.

The Plugable DisplayPort to HDMI 2.0 Active Adapter supports up to HDMI 2.0 specifications allowing for 8 bits per color channel. HDR would require an adapter that supports HDMI 2.0b specification which added support for HDR10 ( the most common HDR implementation ).

At this point I think you are seeing the expected and optimal output. Chroma Sub-sampling is disabled on the Radeon software and negotiated to 4:4:4 between the television and the graphics adapter. The lack of HDR support is expected based on the specifications of the graphics adapter.

Pat
Plugable Technologies
www.plugable.com/support


#7

Ok I know that this adapter cant do 10bit hdr but at least I want to confirm that I am doing 4k@60hz 4:4:4 8bit (nohdr) so basically the only thing that I’m still not sure about is the 4:4:4 because I might have misunderstood your previous post about the chroma Subsampling test. :frowning:

Did you mean I should view the image at its original size (720 from the specified site) or that I should zoom it until it fits the hole screen 100%?? because all the text is easily readable at full zoom but at its small original size the red/blue lines are completely unreadable while most of the rest of the text is still readable. The strange part is that at the original resolution of the image the text is still unreadable even with the hdmi cable without the adapter where amd settings show 4:4:4 (you can see that in the pictures I posted earlier)! Is that normal?

On a side note if I view the same image in its original size on my old 1080p monitor connected with dvi the image is as clear as it can get, even the bottom 2 lines are practically flawless and as easily readable as all the rest of the text.


#8

Hi Kiri,

The image should be viewed at 100%, so it will be quite small on your TV. The text will be very small, but if you can read the lines above the red/blue lines then they should be readable as well. The site I linked to early has some examples of 4:2:2 and 4:2:0 for reference. Please feel free to take an up-close picture of the screen showing the red/blue lines with the HDMI native connection and with our adapter so we can compare the picture quality.

Thank you,

Pat
Plugable Technologies
www.plugable.com/support


#9

I am attaching pictures that I took with my phone so that you can see what I see. the first two pictures are with the adaptor on and the third is with the HDMI native connection. basically I tried a lot of combinations of setting with and without the adaptor and there is no mode or setting that can make the last two lines readable! :frowning: The 4th picture is from my old 1080p monitor with dvi connection where the text is perfectly readable. Even if I use 1080p on my tv instead of 4k that text is still unreadable. Any ideas on what else could be causing this on my tv?

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1729043/1_inline.jpg?1525794786)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1729043/1.jpg?1525794786) !](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1729044/2_inline.jpg?1525794817)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1729044/2.jpg?1525794817) !](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1729045/3_inline.jpg?1525794845)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1729045/3.jpg?1525794845) !](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1729046/3_inline.jpg?1525794872)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1729046/3.jpg?1525794872) !](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1729047/4_inline.jpg?1525794892)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1729047/4.jpg?1525794892)


#10

a clarification about my previous post, I somehow managed to upload the native hdmi picture twice (3.jpg). U can ignore any one of them…


#11

Hi Kiri,

Thanks for the images, it looks like Chroma Sub-sampling is enabled on the monitor using the native HDMI as well as the adapter. Based on the User manual here ( http://kr.eguide.lgappstv.com/manual/… ) we can check some settings on the television to see if this can be resolved.

The first setting to check is HDMI Ultra HD Deep Color ( in the user manual under General > Ultra HDMI HD Deep Color ) please perform the following:
On the remote, select the Home button > Cog Icon > Three vertical dots > General > HDMI Ultra HD Deep Color. Toggle the setting to ‘On’ to enable 4K @ 60Hz with 4:4:4 Chroma Sub-sampling.

Please note, this setting is for the current HDMI input port.

After changing this setting, please disconnect the DisplayPort to HDMI adapter from the computer and television to be sure it powers off, then reconnect the adapter and restart the computer.

Please let me know if this helps,

Thank you,

Pat
Plugable Technologies
www.plugable.com/support


#12

I was aware of the HDMI Ultra HD Deep Color setting on my tv and I had that option enabled from the beginning.

I didn’t know that I should unplug the cable and adapter on both ends to be sure it is powered off so I went ahead and disabled the HDMI Ultra HD Deep Color and then re-enabled it and then disconnected it completely like you suggested but unfortunately it made no difference! :frowning:
I even tried using different hdmi ports on my tv and enabled the HDMI Ultra HD Deep Color for those ports too with the same result. Actually I see no difference in the text regardless of weather the HDMI Ultra HD Deep Color is on or off, the picture is exactly the same.

Whenever I disable or enable that option the tv does go blank for a bit and it blinks a few times so it is trying to do something but I don’t think its working! Any thoughts on why or anything else that I can try?


#13

Hi Kiri,

Thanks for getting back to me, I have been doing some more research into this LG monitor and similar models. Based on a few sources the monitor will not output 4:4:4 picture unless the input has been renamed to ‘PC’. This Youtube video ( https://www.youtube.com/watch?v=8EVN1… ) may be applicable to your television and LG WebOS version, if so, please select the PC icon.

Please let me know if this helps.

Pat
Plugable Technologies
www.plugable.com/support


#14

Ok wow, that actually worked! I didn’t expect the label to have anything to do with it but it did. Changing the “HDMI 1” to “PC” has a big impact on how the text looks. I can now read the bottom two lines, there are no missing lines (like in my previous pictures) and all the letters are fully formed so its readable! Thank you so much for finding this, you are awesome.

Unfortunately there is still a small problem I think. Even though, unlike before, the letters are fully formed in the last two lines they appear too dim, or the red and blue background is too bright, so much that I cant even take a picture to show you how it looks. in every picture I tried taking the text looks unreadable even though I can read it when I’m close to the tv but the phone cant show it… Tts a problem when I’m more than 2meters away from my tv because then I cant read the text, it just kinda blends with the bright background, I can still read the rest of the lines at this distance though.

I tried to compensate by adjusting brightness and contrast settings but then I end up with two extremes. I can ether have the red line perfectly readable from more than 2 meters but with the blue one unreadable and the hole screen way too dark OR I can make the blue line perfect but with the red one unreadable and the screen way too bright.

I realize that at this point this may not have anything to do with the adaptor so its probably outside of the scope of my original question but I’m not sure if that’s the case yet. Tomorrow I will test the hole thing with the native hdmi connection and will let you know if there is a difference. Until then what do you think? From what I described, do I finally have 4:4:4 transmission? If yes any thoughts on how I can improve the visibility of the text in the last 2 lines?


#15

Hi Kiri,

That is great, it sounds like the monitor is now working at 4:4:4 ( uncompressed mode )! I am glad that worked, it is just one of those odd settings. I would expect those lines to be VERY hard to read on a 4K television ( the pixels are generally smaller and this makes small text like this hard to read ) as they are blue text on red and red text on blue, the colors will tend to blend to a violet/purple color. The best tests for color quality is to look at photos, for instance searching for color calibration pictures on your preferred search engine should bring up a number of example pictures and you can compare these to real world images ( or connect the 1080P display to compare the color quality ).

The LG television will have a number of color calibration options, the manual page here ( http://kr.eguide.lgappstv.com/manual/… ) under Picture > Picture Mode I would recommend starting with the Game Mode to see how that looks. Most of the time game modes will disable automatic brightness settings ( which may cause the television to become brighter or dimmer depending on ambient brightness and the image brightness which is very noticeable when using as a desktop monitor ). Picture Mode Settings also has sharpness adjustments, brightness, and contrast settings which may also be affecting the image quality.

Please let me know if the Game Mode helps and if you have any additional questions.

Thank you,

Pat
Plugable Technologies
www.plugable.com/support


#16

So I just tested it with the hdmi cable alone and the results are very similar. I can make only one of the lines visible from a reasonable distance. Only the blue line is clearly visible and the red just sort of blends together. if I also enable hdr with the native HDMI then only the red line is visible and the blue one blends together. to my eyes it looks like a color/contrast problem.

A more obvious difference between the adapter and the native hdmi connection is the vertical lines that are beneath each text. with the adapter they sort of blend in together to form a continuous rectangle instead of the individual lines that are visible beneath the rest of the texts. This doesn’t happen with the native hdmi. To be honest even though neither is perfect if I had to choose I would say that the native hdmi is a bit clearer that the adapter.

Also now that I have the tv in “pc” mode the setting “HDMI Ultra HD Deep Color” does nothing! I mean I disabled it and then re-enabled it, the tv blinks a few times but the picture looks exactly the same, exactly as I described it in the previous post. That’s the setting that enables 4:4:4 according to the manual, how can it be the same when I turn it off? bug in the tv or maybe am not at 4:4:4 yet?

I am attaching a picture of the text with the adaptor and the tv in pc mode but like I said previously the phone cant really capture it well… !](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1729612/DSC_0232_inline.JPG?1526056406)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1729612/DSC_0232.JPG?1526056406)


#17

sorry i posted my last answer before I saw yours. :stuck_out_tongue: its great news that im at 4:4:4: thought, thanks for that! just let me try a couple of more things first and I will get back to you with my final results!


#18

Hi Kiri,

Thanks for the additional image, that looks like more like 4:4:2 compared to the examples on this page here ( https://www.rtings.com/tv/learn/chrom… ) however not exactly like 4:4:2. More options under the Picture menu such as “Advanced Controls / Expert Controls > Super Resolution” may be able to adjust this as well. The native HDMI connection ( and with the adapter ) should both be at 4:4:4 with the input labeled as ‘PC’ and with HDMI Ultra HD Deep Color enabled, the quality of the image may be a problem with settings in the television.

Do normal text and pictures look OK when sitting a comfortable distance from the screen?

Thank you,

Pat
Plugable Technologies
www.plugable.com/support


#19

You are right it does look like 4:2:2. and I don’t understand why the setting “HDMI Ultra HD Deep Color” doesn’t affect the result, like I said before the picture and the text inside is exactly the same with setting off and on. only the “pc” mode makes a difference but its still not good enough.

That said I did do extensive experiments with the tv settings you mentioned and with radeon settings and I did manage to improve the image quite a bit! I want to stay in game mode on the tv picture settings. Under game mode most advance settings were grayed out but changing black level to high and gamma to low did help a bit.

The biggest change I saw was when I change the “hue” setting in radeon. setting it to exactly +15 made the last two lines much clearer and the vertical lines beneath the text can now be distinguished as individual lines!

The problem is that this changes how the colors look and the red line is now a more pinkish red and the text still looks worse than my 1080p monitor (especially when viewed from a distance). All other images, texts, vids and games actually look normal to me. Its just those last two lines in this test that never look good enough (especially when compared to my 1080p monitor).

I feel the need to say that i am a bit disappointed with how this whole chroma tech works (not your fault I know). Since there are a lot of different things that can affect the image as much as the chroma subsampling does then this simple image test can never be conclusive, they should have made a menu somewhere to show in real time at what transmission a monitor is receiving.
Anyway, do you still think that I am at 4:2:2 and I should keep looking for a fix or maybe I am at 4:4:4 and what I’m seeing is just as good as my display can be?


#20

Hi Kiri,

Thanks for getting back to me. Based on the television’s specifications the display should be 4K @ 30Hz with RGB 4:4:4 when connected to the graphics card’s HDMI output and 4K @ 60Hz with RGB 4:4:4 when connected to the DisplayPort to HDMI adapter. The fact both of these settings are being sub-sampled makes me think the issue is in the Television.

There is an updated firmware available from LG here ( http://www.lg.com/uk/support/support-… ) under “Software & Firmware” from 03/04/2018 as well as an update guide PDF file with instructions for updating the firmware. This may help if there is a bug or known issue with the monitor not working correctly with the PC input. Please update the firmware and let me know if that helps.

Thank you,

Pat
Plugable Technologies
www.plugable.com/support