Can't connect to websites using UD-3000


#1

I have a UD-3000, installed the latest drivers from the internet and am having issues connecting to the internet.
Pinging works, I can connect to network shares but HTTP connections aren’t working.
It works fine if I connect the network directly to the laptop or use wireless.
How do I get the internet working through the UD-3000?


#2

Hi Mike-

Thanks for contacting Plugable support, I’ll be happy to help.

To begin troubleshooting having the output from the DisplayLink support tool will be helpful. Instructions to use and download the tool are here: http://plugable.com/support/tools/dis…

Please send the output from the support tool, attention Jeff, to support@plugable.com with a link to this thread.

One possible issue is that only full duplex, not half-duplex networks are supported by the DL3000 chip used in the UD-3000. This means that using an ethernet cable with 4 instead of 8 active wires, or a network hub or switch that supports only half-duplex mode cannot be connected upstream from the UD-3000.

Is the network you are connecting to a home network where the hardware is all under your control or is this part of a a business network?

Thanks in advance for the additional details.

Best wishes-

Jeff Everett
MCITP Enterprise Support Technician
Plugable Technologies


#3

Support tool’s output has been emailed to you.
The cat5e wire plugged into the device has 8 wires.
The switch it is plugged into shows 100Mb full duplex.
I’ve tested on 2 different new computers with nothing else installed, on different networks and had the same result.
I can use ftp, ping and nslookup on the internet. I can connect to local http servers but not internet http servers.


#4

I got a reply back from my email with ticket #24933


#5

Hi Mike-

Thanks for submitting your DisplayLink Logs.

Since we’re seeing different behavior on different connections, and know that at least basic functionality for the adapter on the UD-3000 works, I suspect that this issue is firewall related.

From reviewing installed programs we can see “Managed Antivirus” which seems to provide firewall services as well as antivirus. My best advice would be to check with your IT department regarding using different network connections, or to check your firewall configuration.

I hope this helps, please let me know if you have other questions.

Best wishes-

Jeff Everett
Plugable Technologies


#6

Managed Antivirus doesn’t have a firewall.
The computer is using windows firewall, which I disabled and it still has the problem.

When trying to go to a website some times I get a search page to partially load going to domainhelp.search.com

This is different from my regular search page, when the UD-3000 isn’t plugged in, which is the default of bing.com.

It looks like your device or software is intercepting website requests, failing at something then redirecting to your own search engine.


#7

Hi Mike-

Thanks for the additional details!

The behavior you’re seeing would suggest a DNS level issue. Please rest assured that this behavior isn’t due to the design of the UD-3000, but is a symptom of a network connection that isn’t working properly.

To verify this we can use nslookup to check for the IP address of bing.com:

Plugables-MacBook-Air-2:~ jeff$ nslookup bing.com
Server: x.x.x.x
Address: x.x.x.x

Non-authoritative answer:
Name: bing.com
Address: 131.253.13.32

If you try pasting in 131.253.13.32 to your browser’s address bar you should be able to get to Bing normally. Is this correct? This would confirm a DNS specific issue, and then we can hone in on resolving it once we confirm that.

Please let me know if you get Bing when you visit 131.253.13.32.

Best-

Jeff


#8

I tried that, still not working. I’ve uninstalled my antivirus, still not working.

What do you know about domainhelp.search.com?


#9

Hi Mike-

We suspect you have a browser plugin- specifically the search.com toolbar- that causes this redirect. Please take a look at the steps outlined here and let us know if they are helpful in removing this application.
http://www.pcrisk.com/removal-guides/…

Best wishes-

Jeff


#10

The problem only occurs if the UD-3000 is plugged in.
The 2 laptops this is occuring on are new. I find it hard to believe that they are both infected with the same malware unless it was embedded in your install program.
That search toolbar doesn’t show up in the programs list.

I installed firefox and it has similar problems but only when going through your device.
When going to google through your device I got a content encoding error.

I’ve got 3 of these UD-3000 and so far I’v tried installing 2 of them on 2 different laptops and have the same issues on each.

The problem has only occurred when plugged into the UD-3000 not when plugging the network cable directly into the laptop.

I’m about ready to return these things.


#11

Hi Mike,

I understand your frustration! Thanks for letting us help get the problem solved.

If we can’t solve it now, it’s likely you’ll see issues in the future with redirects to search.com. Search.com is owned by a big US company (CBS interactive), but uses browser plugins and other tricks to drive traffic to it. A real pain.

DisplayLink’s drivers do not install anything related to it - no browser plugins, no DNS redirects. We don’t yet know why only the network interface on the dock is seeing the redirects to search.com, but it’s likely it’s a default for all new network interfaces, that was changed by some earlier software install on both machines.

Weird things can happen, but we’re confident we can solve it, because there are 10s of thousands of DisplayLink-based docks out there, all using the same drivers including ours, and this issue hasn’t come up before. So something special is happening on your machines.

We will find it and fix it. Thanks again for sticking with it until we do!

So to do that, let me step back to make sure I understand where things stand …

You mentioned that pings and network share accesses work fine – the problems have been in the browser so far. Let me know if that isn’t right.

Early on you mentioned HTTP doesn’t work (no web sites work). But later on you said that when trying to go to a website some times you get a search page to partially load going to domainhelp.search.com.

From that it sounds like going directly to specific websites (like http://nytimes.com or http://yahoo.com/) might be working, but that when entering keywords, you get redirected to search.com, rather than the prior default of bing.com that you expected.

Is that all right, or can you correct me?

I’m sorry to step back like this, but it’s super important to understand and fix the issue. If I understand right, then it’s likely that the problem is getting caused by a search.com browser plugin that has been installed on both machines. Either way, we will track down the root cause and fix it.

Also, you mention trying Firefox, but also had another browser. Was that IE (Internet explorer)? Thanks for letting me know that.

Thanks so much for your patience and for letting me know if I’m misunderstanding anything from the details you’ve described. And thanks again for sticking with this until we can have it understood and fixed!


#12

Hi Mike, this article below covers more detail about how to remove the search.com plugin.

It not only covers uninstalling, but also covers removing the plugin individually from each browser, since apparently uninstall doesn’t actually remove all residual pieces:
http://malwaretips.com/blogs/remove-s…

Skip steps 3 and after (that recommend installing 3rd party removal tools).

Please let us know if it looks like pieces of the search.com plugin were still installed, or not. The fact that the redirects are landing at domainhelp.search.com is strongly pointing to this as the cause, which is why we’re focusing on it.

Thanks again for your patience in sticking with this until fixed!


#13

I’m not putting in search terms. If i put in http://www.google.com it either errors out, or goes that search page but only through your device.
If I put in the ip address http:// it has the same issues but only through your device.

So far I’ve only seen the issue in the browsers. IE and Firefox… And only through your device.

I’ve never heard of malware only affecting one interface, it hasn’t affected the wired or wireless interfaces on the laptops.
If it was a browser plugin it should affect all interfaces the same.

It hasn’t had any problems with out your device plugged in.

It happens on 2 laptops and it only started happening after installing the drivers and plugging into the ud3000.


#14

Hi Mike,

I agree that it’s weird that only the network interface of the UD-3000 is having a problem, given that the problem is only being seen in browsers (IE and Firefox). There has to be an explanation that makes sense.

Just googling around, these kinds of problems (where ping works but web doesn’t) can happen more generally to Windows systems with all kinds of network hardware, and they’re hard to figure out when it happens. Here are some examples: http://www.dslreports.com/forum/r2293… http://www.teamliquid.net/forum/viewm…

A common thread is firewall software.

You mentioned that “Managed Antivirus” does not have a firewall. But it seems that it runs on (another) box on your network http://www.orange-business.com/en/mnc… and filters http access to the web (for threats): http://www.orange-business.com/en/mnc…

Is that right? And were both machines that you tested on this same network?

If so, is there any way you can test the dock outside of this network? I’m hopeful that things will just work in that case – and then we can hone in on why Managed Antivirus might be filtering out HTTP access for additional network interfaces on the PCs it manages.

I suspect the fall back to search.com might be happening anytime the machines were unable to connect to their first choice keyword search (bing). I’m assuming that the machines are trying to reach search.com but (like the website you’re actually trying to get to), they don’t successfully load anything. Is that right?

Thanks for helping us piece together what might be happening here, and where I might be wrong. We’ll get this figured out and solved!

Thanks for your patience - I hope in the end this effort will be worth it. It would be easy to just not use the UD-3000’s network interface, but this kind of problem and confusion might crop up some other time if you ever have a USB or other additional network interface on one of your PCs. Better to get it understood and solved now.

Thanks!
Bernie


#15

I mentioned that I disabled the windows firewall.

In this case that is the wrong " Managed Antivirus". The name is to generic. It is a managed version of Vipre from GFI.
To be on the safe side I’ve uninstalled it and still have the same problem.

I’m not aware of browsers having a second fall back search. If I plug directly into the network and put in the address bar “aklsjhdlfakjshdlfkajhsd” it will go to bing and try to look that up. However if I put bing.com in the address bar when your device is plugged in it will either error out or go to that search.com page.


#16

Hi Mike - Thanks for the additional detail. We want to understand if any HTTP traffic is making it through.

Quick question to help with that: when the page you’re going to errors out, and it starts trying to go to search.com – does it fully succeed in loading the search.com page? Does it appear like it’s reaching search.com?

If it can reach search.com (and assuming it’s not a cached copy), then we have a real mystery why other HTTP traffic isn’t making it through.

None of this makes sense yet, but we’ll figure it out.


#17

Just to mention what I’m trying to figure out – if HTTP traffic isn’t reaching search.com, then at least we have a consistent result that HTTP (port 80) is blocked entirely. My assumption right now is you’re seeing two different problems: HTTP traffic being blocked in some way for this new network interface; and then some plugin or software redirecting to search.com when a web server can’t be reached.

If you’ll let us know whether any HTTP traffic is making it to search.com, then a good follow-on test of the plugin theory would be to install a new browser like Chrome (which shouldn’t be affected by past install of browser plugins - only things at the TCP/IP stack level) – and see if Chrome works fine or fails the same.

Thanks for sticking with us on this! Confusing as the results are, I believe we will figure it out in the end!


#18