Cannot open COM3


#1

I am running Windows 7 and just installed a Plugable USB to RS-232 DB9 Serial Adapter with the latest driver 3.3.17.203. when I try and use it with Hyper Terminal or TeraTerm I get: “Another program is using the selected Telephony device. Try again after the other program completes.” Or : “Cannot open COM3” The Device Manager shows: “Prolific USB-to-Serial Comm Port(COM3)” under ports. Why cant I use it?


#2

Hi Tom,

Thanks for posting. If Hyperterminal is being told to connect to COM3 and giving that message, we need to figure out what other piece of software on the system is also using COM3.

Quick thing to try: If you reboot the laptop and try re-connecting to COM3 with Hyperterminal, has the other application hogging the port gone away?

From that, we’ll figure out next steps…

Thanks!
Bernie


#3

Hi Bernie

Many, many reboots, always the same result.


#4

Hi Tom,

OK, if we can’t shake the other application from connecting to COM3, let’s change which COM port is assigned to the USB serial adapter (change the assigned port to COM4 or COM5), and then have hyperterminal connect on that new port.

Here’s how: http://plugable.com/2011/07/04/how-to…

Can you give that a try, and see if that gets us free of that other app?

Thanks for your patience,
Bernie


#5

Hi Bernie

I actually tried that earlier, but failed to mention it. Sorry. I just did it again for a sanity check, setting the port to COM10. Including a restart. Same error message.


#6

Hi Tom,

Hmmm… ok, it’s not yet clear what is opening the COM port first, or causing hyperterminal to not be able to open it. Two more quick things to try:

  1. If you type "hyperterminal’ at the windows start menu, then once it comes up, righ t click and select “run as administrator”, can it then access the serial port?

  2. If you have a different PC handy, does everything work on that fine?

Thanks for letting us know … this is unusual, so I’m suspecting something simple (but not obvious) that’s causing the problem …

Thanks again!
Bernie


#7

Hi Bernie

I tried it on my old XP system and it installed correctly and ran.

I ran it on Windows 7 as admin and it still fails.


#8

Hi Tom,

I’m stumped on this one. The leading suspicion is there’s a 3rd party program running that is opening available COM ports (keeping others from opening them).

Tracking down who’s doing this is a little tricky, but if you’re willing, here’s how I’d go about it:

  1. Download Microsoft’s “procexp.exe” utility from their SysInternals suite (here http://technet.microsoft.com/en-us/sy…)

  2. run procexp from the start menu, and say yes to “run as admin”

  3. Go to menu -> Find -> “Find Handle or DLL…” and type in the string “ProlificSerial” and click Search

That should show any applications that explicitly have the USB serial port open.

If you have a chance to check that and see if any applications come up, that could provide a clue …


#9

Hi Bernie

Tried procexp and nothing showed up in the search box for ProlificSerial.

I tend to agree with you that this is something simple that is just eluding us. If I had had this machine for some time I might suspect I downloaded something some time that is causing the problem, but it is only a few weeks old and I have not had too much of a chance to crap it up yet.

One thing that I even remotely suspect is that I loaded Oracle’s VM VirtualBox software and installed a Linux environment. I double checked and the serial ports on the VM are disabled and the VM software is not started or running unless I explicitly do it, so I don’t really think it is the culprit, but it’s all I can think of right now. Short of uninstalling the VM software (which I really don’t want to do) I am not sure what to try next.

Something I have not tried is bringing up the VM and seeing if I can use the COM port under Linux. I am just getting familiar with Linux, so it could take me some time to figure out, and I am not sure how that would ultimately help in the Windows 7 environment.

Do you know of any issues when VM’s are present? I originally tried using Microsoft’s VM, but found some short comings and abandoned it for Oracle.
Like I said, neither are running unless I explicitly start them.

That’s the news from here.


#10

Hi Tom,

VirtualBox has the ability to assign USB devices to the VM (in 1.1 mode with std edition; and 2.0 mode with Oracle VirtualBox Extension Pack http://www.virtualbox.org/wiki/Downlo…). It’s a little bit of work, here’s a start: http://automation.binarysage.net/?p=1261

That will work with this adapter. So if getting it running in Linux in a VM might be a useful workaround, but if you’ve never used USB devices with VirtualBox, it can take a bit of fiddling. But looking into it might also confirm or not if VirtualBox may be the entity already grabbing the COM port.

We’ve heard that some security software (in their scans of devices and files) can hold open COM ports - that’s another area to think about.

Best wishes,
Bernie


#11

hi sir i am muthu i have problem please give me solution i trying to connect with sim900 modem!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1092403/Untitled_inline.png?1409164830)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1092403/Untitled.png?1409164830)


#12

Lol 5 years later I have the same problem. R.I.P Harambe


#13