Cannot get Surface 7 to show all monitors when connecting to Remote Desktop

I just purchased the USB-C to use with my Surface 7 but it will not display on the other monitors when I connect to Remote Desktop and click the “use all monitors” setting. Is this a problem with the Surface7 or is it a Remote Desktop issue? I could try to connect a Lenovo but it does not have a USB-C connection. Can you help me with this?


Thanks for posting!

Are you using Window’s Remote Desktop Connection tool? If so, can you confirm which version of this application you are using? Microsoft has two versions available for Windows 10 – one version called Remote Desktop Connection and a newer version found in the Microsoft Store called Remote Desktop.

I do want to be transparent and let you know that our docks have no control over the behavior or functionality of RDP sessions. There are further complications with remote sessions as there are requirements for both the host and server in which you are connecting to.

We’ll do our best to assist, but this may be something out of the realm of support we can provide.

Thanks for giving us a chance to help!


I am using an older version. I saw a previous thread on this issue with no resolution. My husband has an LG Gram that is able to connect to all monitors using the Remote Desktop connection but it will not work on my Surface 7. Is it the Surface that is the problem? I have the “use all monitors” option checked.

Is your husband connecting to the same remote location as you? Or is he connecting to a different Windows server (or computer)?

Next, can you let me know what version of Windows (or Window Server) is currently installed on the remote system in which you are connecting to? Not all versions support multiple displays.



This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.