Cannot get Gigabit on Catalina

bought a UD-CAM from Amazon, and I am having trouble to negotiate Gigabit Ethernet with my MacBookPro(2016) with Catalina 10.15.7

I’m using the USB-C cable that i found in the box, which is reported as 5Gbps in the system report (so shouldn’t be the problem) and also Ethernet Cable + Router that I know are capable of Gigabit - If I use another Ethernet adapter, it negotiates 1Gbit easily.

Things I tried:

  • Power Cycle,
  • update Realtek Driver (as found in other old posts)
  • force 1000baseT/1500 MTU in the network settings of the NIC

Thanks for help

Hi Emanuele,

Thanks for posting!

What are you seeing as your Link Speed in your Network Utility window (located in the /System/Library/CoreServices/Applications) for the Plugable UD-CAM dock’s Ethernet interface?

In the meantime, are you seeing the same Ethernet speed issues through a Thunderbolt 3 port on the opposite of the MacBook Pro?

Thanks for giving us a chance to help!


Thanks for replying mitchell. The Network utility reports:

Screenshot 2020-10-27 at 17.58.46

I didn’t understand the “opposite” sentence sorry - what I tried is using a Thunderbolt 3 Ethernet adapter (Apple original) with SAME eth cable + router, and it reaches 1 Gbit.

Thanks for getting back to me.

What I meant by “opposite” is to connect the Plugable UD-CAM dock to a Thunderbolt 3 port on the other side of the laptop. For example, if you are currently connecting the dock on the left side on the MacBook Pro, please try connecting it to the right side.

Next, I’d like to proceed by removing all network device entries from System Preferences (not including WiFi). Then we’ll want to save, reboot, then try to add the USB 10/100/100 LAN connection again.

Could you please let me know if that makes any difference?

Thank you!


:open_mouth: IT WORKS!
Screenshot 2020-10-27 at 18.48.36

Mitchell, thanks for the fast and flawless support. What was the root reason? Should it happen again in the future?

BTW I’m about to go to Amazon and stamping a 5 star review on your product, really deserved

Ok spoke too soon. It quickly reverted to 100 Mbit, for no apparent reason :confused:
It happened just as i tried to fire a “speed test” (the OOKLA one)

Tried also to repeat the procedure, it doesn’t help. Stays on 100 Mbit forever :frowning:
Also the opposite side ports, same behaviour

Sorry to hear that didn’t help.

At this point, I’d like to request some logs from your MacBook Pro to best investigate further. Could you please keep the Plugable dock connected (with the Ethernet cable still attached), then navigate to our PlugDebug tool and follow the instructions there?

Please send the file that is created to us at and include “Ticket #322675” in the subject line.



1 Like

After working directly with the customer, we sent a warranty replacement dock which resolved the issue of less-than-gigabit Ethernet speeds.

For anyone else having this issue, please feel free to post a new topic or reach out to us at support@plugable. We’re glad to help.

Best wishes,


1 Like