Can a Motorola Moto Force Z be connected to Ethernet?


#1

Will your USB2-OTGE100 (with a Micro-B to Micro-C adapter) or a USBC-E1000 work on a Motorola Moto Force Z? I bought the USB2 for a Motorola Droid Turbo 2 but was told that the Moto Force Z would also work … it isn’t (or I’m doing something wrong). It currently is running Android Version 6.0.1 Would an update help? or make it worse? or it won’t work period? HELP! He he!

I react strongly to Wifi emissions. Holding a phone in my hand on wifi for 15 minutes makes my hand throb. If I sleep with either the Wifi from my router on or the wifi on my phone on (or location), I wake with a migraine within an hour. I have converted everything in my house to run on ethernet and now I’m trying to get a phone connected so I can shut off the wifi on my modem. Any help would be appreciated. Thanks!


#2

Hi Edwin,

Thank you for posting here.

As you know, the compatibility of Android device with an external USB device such as the Ethernet adapter is device dependent. In this USB2-OTGE100 Ethernet adapter’s case, if the smartphone is running the device driver of AX88772 chip set, it can work. Otherwise there isn’t any way to make it work since Android doesn’t allow users to install any device driver.

Unfortunately we have not tested nor heard about the new Motorola Moto Force Z with the USB2-OTGE100 yet. We do not know if the phone is compatible or not.

But as far as we know, Motorola has been very good at supporting this adapter, with their legacy smartphones with a microUSB port. I personally think it is highly possible that the Moto Force Z has built in the device driver. But in that case, we would suspect either:

  1. The device driver may have problem with the brand-new device. This happens with the Nexus Pixel phone, too. In that case, applying the latest update to Android could be helping. If something wrong happened with the device driver of Android, that is the only way to fix the issue. (But we are not sure if the fix has been or will be delivered or not.)

  2. I am a bit carious what kind of “Micro-B to Micro-C adapter” you are using. That kind of adapter could be the issue.

We have an USB 3.0 Ethernet adapter with a USB-C connector, but we are not sure if it works with the Motorola Moto Force Z phone or not, neither.

Could you contact us directly so that we could help you further? I have a few ideas to figure out which Ethernet adapter could be working.
The email address is support@plugable.com.

Thanks!
Sachiko
Plugable Support


#3

I’m using a Samsung Micro USB to USB-C Adapter, part number EE-GN930BWEGUS, purchased at Best Buy.

I updated the phone to Android 7.0 but still no LEDs light up nor any internet connection when in airplane mode. I thought the adapter I bought at Best Buy was a passive device. I’m willing to try the adapter you recommend from Pluggable.com … Thanks! My phone is (606) 615-8353 if you wish to call. Thanks again.


#4

Erwin,

Thank you for sending us the support email!
I think “passive” micro USB to USB-C should be fine. In any case, I’ll write more details to you directly.

Thanks!
Sachiko


#5

I am not positive that that adapter I purchased is a passive device. I have my suspicion that it’s not.


#6

The E1000 USB-C adapter works fine with the Moto Z and the Moto Z Play. I just tested it out.


#7

Hi Stuart,

Thank you for posting the information!

We have confirmed by Edwin that the following adapters worked fine with his Moto Force Z phone.

  • USB2-E100 + USBC-AF3 (Plugable Type-A to Type-C adapter)
  • USBC-E1000 x 1

It is great to hear that both Moto Z and Z play are compatible with USBC-E1000 adapter.

Thanks again!
Sachiko
Plugable Technologies


#8

As a note of concern for OP.

If you have a Moto Force Z, make sure to never enable 3G or 4G connectivity.

Those phone frequency band ranges include the same exact frequencies as Wi-Fi devices, such as routers, and PC wireless network cards.

Since this is enabled by default for most Moto Force Z users, I am sure you were already aware and have disabled all data settings on your Moto Force Z. In case you haven’t though, out of concern, I would recommend disabling data access on that phone.


#9