Camera fails on third use

Greetings! I ran a search and I don’t see an answer to my problem, so I’m posting here in the hope that someone can point me in the right direction.

I installed the Plugable USB 2.0 Digital Microscope on my Windows 10 laptop this morning, and everything went smoothly. The second session with the microscope an hour later also went smoothly. But when I tried to use the Microscope the third time, it failed. It appears that the camera is not receiving power from the USB port because there is no light on the camera (even thought the light is turned up to full bright).

When I go to Settings, and then go to the drop down menu that controls the camera choice, the Plugable USB digital microscope is selected, but what is actually showing on the Plugable Viewer screen is the laptop’s installed cam. I have changed the sellector to the installed cam and back to the Plugable USB microscope repeatedly, but it doesn’t change the display from the installed laptop cam.

I have also uninstalled the Plugable driver and reinstalled it, and I have tried rebooting repeatedly. None of this does any good.

I should also mention that I tied the device on several known good USB ports on two laptops, and the camera did not appear to get power from any of them…

Right now, the thing is stone cold dead after two uses. Any suggestions?

Bruce Brown

Thanks for reaching out!

It sounds like the app may have the names of your webcams swapped in the UI. This isn’t terribly uncommon, almost all webcams use the same driver so it can be tricky to correctly associate the device name with the device.

Can you try selecting every device available in the Devices drop-down menu and see if you can get output from the microscope? You should see the LEDs light up if it’s accessed.