Brand new UD-ULTC4K stuck in 640x480


#1

Hi

I have a Surface Book 2 with two identical external monitors connected via the Plugable UD-ULTC4K dock. One monitor is connected via HDMI and works fine. The other is connected via display port and is stuck at 640x480. Initially when I first connected the dock up it all worked fine. But after an undock and redock one of the displays switched to 640x480 and will not allow me to change it (the option to change the resolution is greyed out).

I found an article on your forum giving details to uninstall the DisplayLink app, then run the cleaner app the reinstall the latest driver - I followed this but it has not made any difference.

I have tried powering the laptop off and on, tried the dock off and on, tried just the problem monitor on its own - but the issue remains. I have also tried switching the monitor cables around and the problem then moves to the other monitor - so I do not think the issue is with the monitors.

Do you have anything else I can try?

Thanks


#2

Hello Tim,

Thank you for contacting Plugable support! Sorry to hear about this issue. I’d be more than happy to assist you.

We have a troubleshooting tool that helps us find out what is going on in situations like this. Please plug the device into your computer, then go to this page and follow the instructions there:

http://plugable.com/support/plugdebug

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry

Senior Engineer
Plugable Technologies


http://plugable.com | http://performance.plugable.com/


#3

Hi, I have submitted the logs to the support email address.

Thanks


closed #4

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.