Boot Issue when DisplayLink UD-160-A is Connected


#1

I have a UD-160-A. It worked flawlessly for 6 months. Now, my computer will not get past the boot screen with the DisplayLink device connected to a USB port. I must completely boot into Windows 7, let everything load, and then connect the device to the USB port. Then the HD reads for at least 5 minutes before it finally IDs the DisplayLink and loads my external mouse and keyboard. The external monitor, incidentally, works almost immediately when I connect the DisplayLink device to the USB port.


#2

Hi Frank,

Thanks for posting your question here, we’ll be happy to assist. First, can you say a bit more about your setup? Do you have an external DisplayLink device other than the one in the UD-160-A? What’s the make and model of computer you are connecting to? What type of USB devices are connected to the UD-160-A?

Let me know these additional details and we’ll figure out next steps.

Thanks,
Jerome.


#3

Lenovo x201 with Windows 7 Pro. The UD-160-A connects directly to the computer. Connected to the UD-160-A is a TrendNet KVM switch. An Acer flatscreen monitor, an MS wireless keyboard, and a Logitech trackball are connected to the KVM switch. A Plantronics USB headset and a 1/8" speaker plug are also connected to the UD-160-A. This setup worked perfectly until suddenly it didn’t, and the computer started freezing at the boot screen when the UD-160-A is already connected. Actually, if I remove the USB to the UD-160-A, the boot resumes.


#4

Hi Frank,

Thanks for the extra details. Let’s try booting with just the UD-160-A attached to the computer via USB but with no devices attached to the UD-160-A. I suspect this will boot fine, if it does, next connect your devices one at a time verifying it boots each time, with the wireless keyboard last.

My suspicion is that you’ll find that the wireless keyboard hangs up the boot process. Let me know if this is the case and we’ll figure out what to do next.

Thanks again,
Jerome.


#5