Bluetooth dongle's custom media playback dialog steals focus from full-screen PC games when switching tracks, any way to stop this?


#1

Hey all, so sometimes I’ll listen to music or podcasts from my phone while playing some of the less plot-heavy PC games, and this hasn’t been a problem until I started using this dongle from Plugable. Now, any time my phone changes tracks, the playback dialog window pops up in the lower right corner of the screen, and kicks me to the desktop. I’m not finding any options to change that might help stop this from happening, does anyone have any suggestions?

Here’s a pic of the window I’m talking about:
!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1278896/bt_inline.jpg?1442619819)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1278896/bt.jpg?1442619819)


#2

Anyone?


#3

Hello David,

Thanks for contacting us about this issue!

Are you saying that you used a different Bluetooth solution before on the same exact machine and didn’t have this problem? That dialog is actually a part of Windows Media Player, and is the default behavior for any Bluetooth adapter.

To disable it, you have to turn off the remote control features. Give this a try:

  1. Press the windows key, or hit the start button, then type “Devices and Printers”, and press enter
  2. Right click on your phone and select Properties, then navigate to the Services tab
  3. Uncheck “Remote Control” and “Remotely Controllable Device”

This will disable remote control of your phone, so you will have to change and pause music from your phone interface, but that popup should go away.

Let me know if that works!

Cheers,

Sam Morgan
Plugable Technologies


#4

Yep, I previously was using an ASUS branded dongle, (windows provided all the needed drivers) which used an older 2.x BT spec, and would occasionally have buffering/stuttering issues with audio streams. I never had the focus-steal issue while using it. The remote control window actually looks a bit different using the Plugable dongle/drivers than it did with the ASUS one, (the differences aren’t extreme, but if I had a screenshot of both, the differences would stand out). One huge difference is that when I closed the remote window, it would stay connected to the phone. Any time I click the X to close the remote window while using the Plugable dongle, it disconnects from my phone.

I followed your directions and actually unchecked everything except “Advanced Audio” (pic included),
!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1283631/bt2_inline.jpg?1443380462)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1283631/bt2.jpg?1443380462)

but this remote control window keeps showing up. I think you’re on the right track, trying to disable the remote entirely, as I actually prefer controlling media directly on my phone.

Thanks for the reply, I’ll keep messing with it until you get back to me, and I’ll post here if I figure anything out in the meantime.


#5

Thanks for giving that a try!

I tested this myself on one of our Windows 7 machines in the office and had the same results as you. The final answer appears to be that there is no fix for this.

The offending program isn’t Windows Media Player as I had originally thought, but BTStackServer.exe, which is the main component of Broadcom’s WIDCOMM Bluetooth software. Disabling this exe stops all Bluetooth connections on the machine, and turning off notifications for that tray icon does nothing.

So, unfortunately, this can’t be fixed on Windows 7. The only option going forward to remove this annoyance using our adapter is to upgrade to a newer version of Windows (10 is free!), or returning it and trying a different adapter with a non-Broadcom chipset.

If you’d like to return the adapter, I’m happy to help with that!


#6

Well, I appreciate your efforts! Knowing that it works properly on Windows 10 (it does, right?), I can live with that. I’m just waiting on some proper Oculus Rift support for Win10 before I upgrade, and until then I’ll just use a line-in cable rather than go to the trouble of exchanging the adapter. Thanks again!


#7