Bluetooth adapter4.0 won't install in pavilion g6 windows8


#1

Just purchased the usb Bluetooth adapter 4.0 for my Pavillion g6 and when I install it nothing happens what’s going on?


#2

Hi Stephan,

Thanks for posting! We’ll be able to help.

When you plug into an Internet connected Windows 8 machine, Windows will automatically download the right (Bluetooth HCI) driver from Windows Update, and use the built-in Windows 8 Bluetooth functionality automatically.

Have you used the Windows 8 UI before, to pair with another Bluetooth device? And can you say what Bluetooth device make / model you’re trying to connect to - we’ll tailor any steps for the kind of device you have.

But generally with Microsoft’s built-in Bluetooth stack, the steps are:

  1. Hit the Windows-C hotkey to bring up the Windows 8 “charms menu”
  2. Choose Settings (4th item down)
  3. Choose Change PC Settings (bottom right)
  4. Choose Devices in the PC Settings menu
  5. Put your Bluetooth device in pairing (or “discoverable”) mode. How to do this depends on each Bluetooth device – usually it’s a button on the device.
  6. Choose “Add a device” back in Windows 8
  7. Select your device when it comes up, and exchange pins if needed.

Let us know if we can help, or if there seems to be a lower-level issue with the USB Bluetooth adapter.

Thanks!
BErnie


#3

Hi. I have an HP Envy dv7t Quad Edition and the Bluetooth USB Adapter is not finding my Plantronics BackBeat 903+ headset. The adapter drivers installed fine. Please help.

Jay
Orlando, FL


#4

Actually, I think I discovered my issue. My download of the WIDCOMM software from Broadcom’ site using Google Chrome was broken. I downloaded the WIDCOMM software using IE 10 and everything should work fine after a reboot. Windows 8 is okay!

Jay
Orlando, FL


#5

Well, even after I did everything as instructed, my Plantronics BB903+ headset is still not being detected with the Bluetooth USB 4.0 adapter. I tried 2 different USB ports in the HP Envy dv7t Quad Edition with the same result. Please help!

Jay
Orlando, FL


#6

I finally resolved the issue. I did not hold down my power button on the headset long enough.Now to tweak the sound a bit.

Jay Bader
Orlando, FL


#7

Hi Jay - Thanks so much for self-solving the issues and replying back, so others who might hit the same things can see the solutions. Post here or email support@plugable.com to contact us directly for any other questions or issues - we’ll be happy to help (we’re all in Seattle, so we get in 3 hours later than the east coast …)

Thanks again!
Bernie


#8

Does this include driver support for Windows 8 64-bit?


#9