Blinking monitors connected to Thunderbolt 3 docking station (with power)


#1

I have Thunderbolt 3 docking station (with power) connected to Dell XPS13 (mid 2016) laptop. My two 4K monitors, which are connected to it, keep blinking from time to time. Very annoying. Updated all drivers/firmware, became better but still blinks. Helps if I reduce refresh rate to 30Hz ( instead of 60Hz) but such speed sucks. All hardware is supposed to work with 60Hz. I use for speed Thnderb.3 certified cables… Any solutions/suggestions?


#2

Hi Igor,

Thanks for posting – sorry to hear about the issues but we’ll be happy to help.

A few quick suggestions:

  1. If possible, can you please test to see if running the XPS in Airplane Mode helps the behavior? (Some Dell systems have issues with wi-fi interfering with data transmission on their USB-C/Thunderbolt 3 ports: https://plugable.com/2016/06/30/inves… )

If Airplane Mode fixes the behavior, there are some specific fixes/work-arounds we can try.

  1. If Airplane Mode doesn’t help, it will help to know a bit more about the setup details:
    -Brand/model information from the monitors would be helpful.

-Also, any details about how they are connected to the docking station. (Is the first display connect directly using a DisplayPort cable to the dock? And is the second monitor using a USB-C to DisplayPort cable, or something else? Which brand?)

Thanks!
Gary


#3

Thanks! Miraclely Airplane Mode works!
>If Airplane Mode fixes the behavior, there are some specific fixes/work-arounds we can try.
Can you please share, which ones?


#4

Hi Igor,

Great news that Airplane Mode helped!

For some Dell wi-fi cards, the radio power can be reduced which can help with interference. (Also, many users have reported that if they have a Dell or “Killer” brand wi-fi adapter which does not support adjustable power, that they have contacted Dell and explaining the issue, Dell has sent them a replacement Intel wi-fi card which supports adjustable power.)

Can you please see if your card supports this setting and try reducing the power to see if it helps?

Also, sometimes connecting to a 5GHz wi-fi network rather than 2.4GHz can help.

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1688575/ScreenShot2018-01-03at9.50.58AM_inline.png?1515002677)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1688575/ScreenShot2018-01-03at9.50.58AM.png?1515002677)


#5

Thanks!


closed #6