Black screen on & off


#1

My Plugable 3900 started going black in recent days. I had this problem a long time ago and it’s been great for a very long time. The frequency changes…yesterday was almost non-stop…today it is better. I’m running version 7.5 and saw problems with 7.9 and some new Windows updates. Could the 7.9 problem also effect version 7.5? HELP!!! the black screens are driving me crazy.

Thank you


#2

Hi Jerry,

Thanks for posting, and I would be happy to help with your docking station.

If you are in fact using the 7.5 version of the DisplayLink driver, that is a much older release than we recommend and to our knowledge is not affected by the same behavior that some users of the 7.9 M4 version have experienced. I would recommend installing the latest version for your operating system from our download page here --> http://plugable.com/drivers/displaylink to see if that changes the behavior.

If you are still experiencing issues after upgrading the driver, please keep everything connected and send the output of our diagnostic utility PlugDebug --> http://plugable.com/support/plugdebug to support@plugable.com with "Ticket 133443’ in the subject line as this will allow us to examine some log files from your system to help determine the next steps. If you could also include your Amazon Order ID number that would be most helpful.

Thank you,

Bob
Plugable Technologies
www.plugable.com/support


#3

Bob:

Thank you for the quick reply. The device is over 2 years old and the order number is 104-2849099-4909006. I will try you suggestions in the next couple of days, since I will be out of the office a lot the next couple of days.

Thank you and I’ll be in touch.

Jerry


#4

Bob:

Sorry to bother you again. The link to the updated driver shows 7.9 M3 and your mentioned M4. Just want to make sure I get the correct one.

Thank you

Jerry


#5

Hi Jerry,

Thanks for getting back so quickly. Plugable recommends the 7.9 M3 driver, but some have elected to upgrade to the latest release which is 7.9 M4. A small number of customers have experienced issues with that version, so we made a post about the behavior with a solution here -> http://plugable.com/2016/01/19/flashi…

In your case we want to start by performing the clean install with the recommended 7.9 M3 to establish a baseline and work forward from there.

Thank you,

Bob


#6