Audio skipping on windows 10

Whenever I listen to music with the dock plugged into my XPS 13 9300, there is an audio stutter/skip every 10-20 seconds. It’s quite frustrating. The dock is the UD-3900. Any advice would be appreciated.

Hi Dan,

Thanks for reaching out to us, I am sorry this is not working as expected and I am happy to help!

I would like to start by getting some additional details about your setup, when you have a moment please let me know the following:

  1. Is the audio being played through a HDMI display connected to the docking station or through speakers or headphones connected to the 3.5mm audio port on the docking station?
  2. Are any other devices experiencing problems, for example delayed or intermittent typing on the keyboard or mouse movements, or flicking displays?

We can also gather some log files from the system to look for common software problems that may be causing this unusual audio behavior. If you would, please keep the dock connected and all devices connected and attach the output of our diagnostic utility PlugDebug ( http://plugable.com/support/plugdebug ) to an email to ‘support@plugable.com’ with the subject line “Ticket #300760 - Attention Pat” as this will allow us to examine some log files from your system to help determine the next steps.

Thanks,

Pat
Plugable Technology
support@plugable.com

Hi Pat,

Thanks for getting back to me. The audio is being played through a set of speakers connected to the 3.5mm headphone jack on the docking station. I’ve had 1 instance where the keyboard and mouse stopped working, and a couple of instances with monitor flicker, but that hasn’t happened for a few days now. I’ve sent an email with all the above information, as well as the attached file from the debugging tool.

Thanks,
Dan

Hi Dan,

Thank you for sending the log file, based on the logs the drivers are up to date and the computer is using the correct driver for the docking station’s audio controller.

Does this only affect music played through a specific application or is all audio affected, for example is a Youtube video affected?
Does using another browser, for example using Edge Browser or Google Chrome change the audio issue?

I would like to reset the docking station and computer to see if this helps to restore the functionality, please perform the following:

  1. Disconnect the docking station from the computer and remove the power connection from the back of the docking station, unplug all USB devices and displays from the docking station
  2. Disconnect the docking station’s power supply from the wall and let both the docking station and power supply sit for 30-90 seconds to fully discharge
  3. Restart the computer: In Windows 10: Start -> ( Power Icon ) -> Restart
  4. After 30-90 seconds, reconnect the power supply to the wall socket or power strip
  5. Reconnect the power supply to the docking station
  • verify the blue power LED is illuminated on the front of the docking station, please let me know if this does not come on
  1. Reconnect the docking station to the computer, please verify the USB cable is fully seated in both the docking station and the computer
  2. Connect the speakers to the docking station with all other devices disconnected and test with playing an audio file or Youtube video, please let me know if the intermittent audio is still occurring
  3. Reconnect Displays and USB devices to the docking station one at a time with the audio test playing and let me know if connecting one specific device causes the audio problems.

Please let me know if this helps, if not we can go from here.

Thank you

Pat
Plugable Technology
support@plugable.com

Hi Pat,

This seemed to have worked for now, but occasionally the issue persists and I have to repeat the procedure. I’ve also noticed an issue where the all the monitors turn on and off for a brief second.

Hi Pat,

Unfortunately the issue is still present.

Hi Dan,

I am sorry this is still being problematic.

We can continue to try and narrow down the cause of this behavior:

1 - Does this only affect music played through a specific application or is all audio affected? For example does this happen to music or video played through the web browser as well as from mp3 files stored locally on the computer?

1A - If only some applications are affected, please let me know which specific applications, for example if the issue happens with Google Chrome but not with Edge browser.

2 - Please disconnect all USB devices from the docking station, except the keyboard and mouse and let me know if the issues continue. For example, if you have a USB hard drive connected to the docking station please disconnect it from the computer entirely for the duration of testing the audio. All USB devices share the USB bandwidth and if the audio skipping is being caused by another connected device this should eliminate that possibility.

3 - If the display connected to the HDMI output of the docking station has built in speakers. Can we disconnect the speakers from the docking station and see if the issue persists through the display’s speakers?

Thank you for these additional details, they will help to narrow down this behavior.

Pat
Plugable Technology
support@plugable.com

Hello,

We’re closing this thread due to inactivity, but if you have any further questions please feel free to contact support@plugable.com and we’ll be happy to help.

Thanks,

Pat
Plugable Technologies