Audio Driver Not Installed


#1

I have an HP Pavillion and have the PLUGABLE UD-3900 DUAL DISPLAY UNIVERSAL DOCKING STATION. I am not able to select the audio to HDMI and have verified that the device is not properly installed as it still shows up under Other Devices when viewing in Device Manager. I have tried doing an internet scan for the driver and uninstall and rescan for new devices but the driver is still not installing. I have looked on the site for audio driver but have not found an available driver for download. Any help is greatly appreciated.


#2

Hi Abel,

Thanks for posting! I’m sorry the audio isn’t working properly over HDMI from the dock. I’d be happy to help.

The audio driver for the dock is included with the main DisplayLink driver (along with the Ethernet adapter driver). The first step would be to clean the current drivers from your system and install the latest we recommend. Please follow these steps:

  1. Disconnect the dock from the computer and please remove the power cable from the dock so it turns off completely. Please keep it disconnected until the last step.

  2. Uninstall the DisplayLink Core software from Control Panel->Programs. Don’t worry if this fails, just move onto the next step

  3. Download and run the DisplayLink cleaner tool, found here:
    http://displaylink.com/techsupport_fi…

  4. Once the Cleaner has been run, reboot (even if not prompted to)

  5. Now download and run the 7.7 M3 DisplayLink software, found here:
    http://displaylink.com/support/sla.ph…

  6. Reboot, even if not prompted to

  7. Once you’re back in Windows, reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your PC which will trigger the final portion of the installation

Please let us know if that helps and allows the audio to function, and we can go from there.

Thank you,

Bob
Plugable Technologies
www.plugable.com/support


#3