Audio Driver causing logon issue


#1

After troubleshooting it seems we are having an issue with the audio drivers for the Plugable USB 2.0 docking station. When we are not connected to the plugable and we boot we are getting an error message that begins with “windows could not connect to the system event notification service…” and our start menu and taskbar reverts back to the “old” grey start menu look from windows 2000. When checking event viewer it gives me an error that the audio service could not be started.

Quick (Sorta) Troubleshooting Description:
Re-imaged a computer and could not replicate the issue after testing
Plugged in the plugable and let it install everything, and rebooted
After this reboot (With plugable still plugged in) everything was Ok
Shutdown PC, unplugged everything (Power, ethernet, and Plugable) and booted
This boot I received the above issue.
The doesn’t seem to affect anything but the look of the start menu.
If I log off and back on everything seems to go back to normal.

We have deployed several of these docking stations in our environment for a 3 monitor setup for our laptops and several people have complained of the same issue.

As a work around (Besides logging off and back on), we have disabled the USB Audio in device manager and this seems to resolve the issue, but we feel this shouldn’t be a fix as some users might want to use the plugable to connect speakers or something.

Any Help is greatly appreciated

System Specs:
HP 8540w
Intel I7 M 620
8 gigs RAM
Windows 7 Pro x64

NOTE: Not sure which plugable we have as they both look Identically on your site and there is no identification on the product or packaging.


#2

Just noticed in device manager that we are using the UD-160-A docking station


#3

Hi Tim,

Very sorry you’re experiencing this problem! Thanks for posting this great detail.

It’s extremely interesting (and surprising) that disabling the USB audio device seems to work around the issue – because what reports we can find of the same error (reports on other non-Plugable hardware like this http://social.technet.microsoft.com/F…) pins it as a networking problem. It seems to be coming up more frequently in recent months on a variety of Windows 7 systems with a variety of attached devices.

(by the way, it appears when this error is triggered, for some reason it disables Windows Aero, which might explain the change in appearance of the taskbar, that you’re describing)

Let’s try to hone in on a few things:

  1. Can you confirm that the problem is intermittent (doesn’t happen every every time the machine boots)? Or is it 100% when it starts happening?
  2. Are your users who are hitting the problem using the network interface of the dock, and does that seem to matter for recreating the problem?
  3. By default, the USB audio device on the dock gets matched against the Microsoft-provided standard audio class driver. But we also provide a custom one for the C-Media CM6300 on CD, largely for users wanting finer volume control. Do you know which driver is in use on the machines where disabling USB audio makes a difference? (check properties of the device in device manager. If you didn’t go out of your way, it will be the default Microsoft driver).

Thanks for letting us know about these things, and thanks for our patience while we get this figured out!

Bernie


#4

Bernie,
Thanks for such a quick reply. We did go through the different MS settings and ran a couple winsock reset commands and also a SFC command or two per articles we found. All to no luck.

Question 1:
This seems to be intermittently intermittent (I know confusing). For most the time, we get it to “break” with certainty by having everything unplugged, but at the same time we have had users state it doesn’t always happen when unplugged. We have also had reports that the users are plugging everything in (including plugable) before booting and still receiving the error and sometimes not.

Question 2:
Our users are using the network interface on the dock. I just did some additional testing, with the ethernet cable plugged into the laptop and not the plugable. With the USB Audio driver enabled, received error when plugable is not plugged in. With USB Audio Driver disabled, do not receive error. So it does not seem to matter

Question3:
We are using the MS one, which I believe is pulling from MS Updates when we plug in the plugable. I looked for an audio driver on the CD provided, but was only a setup.exe on the disk. When running the setup, it doesn’t seem to put any other audio driver on my system.

The driver info:
Provider: Microsoft
Date: 7/13/2009
Version: 6.1.7600.16385

I have tried doing an update, and its says I currently have the most up to date.

Thanks Again


#5

Hi Tim,

Thanks so much for these extra datapoints! Focusing in more, there some stuff that’s confusing that I want to make sure I confirm/understand:

A) Without the dock software installed, the problem doesn’t seem to happen (for background, the dock software is really an independent DisplayLink driver for graphics, ASIX driver for network, Microsoft driver for audio, and Microsoft driver for hub)

B) Once those drivers are installed fully (after plugging in the dock once), the problem then can happen with or without the Plugable dock actually connected. Is this right?

C) Disabling the “USB Multimedia Audio Device” (the audio function of the dock) in device manager causes the problem not to happen.

Are any of these statements not true? (I know this is tough to answer, because the problem is intermittent at best! :))

The confusing part is B) should cause the USB audio device to not be present, really in pretty much the same way the C) does. I would expect they would get the same results.

Making sure about which audio device is getting disabled, Is this the name of the audio device which, when disabled, avoids the problem?

!](https://sslproxy.getsatisfaction.com/sslproxy/SWhAdDNLMG5zdGFuVGlWenmLbJDGd3CABhjZermgcystANA4T6nd0pzV0fSzBRRGOd17A4b8ZLwi6-HESbXI0qXUKY1LDvgbe33a6vNh6oxH_em7cG-G6FYstxRfa9CioYaGA0ROOTpTrq7qM-RJwE5SpzhdOlO-nquP9c-asOL58VKgHCNO-yzZjGC5nCoq.PNG)](http://s3.amazonaws.com/satisfaction-production/s3_images/433655/ud-160-a-device-manager-audio-device.PNG)

(and for that device, in properties->details->hardware Ids, you should see
USB\VID_0D8C&PID_0105&MI_00 in the list)

Thanks for the additional info - this is certainly an interesting mystery! We’ll get it solved.

Bernie


#6

Bernie,
Statement A:
Statement is correct

Statement B:
This is true, with a side statement. I have only been able to get it to fail during my own testing while the plugable was NOT connected. It is the user stating that they are plugging in everything before booting and I can only go by what they are telling me.

Statement C:
Statement is correct

You are correct about the device not being visable in device manager, it is not visible unless I have the plugable plugged in.

“USB Multimedia Audio Device” is the name of the device that we are disabling. I checked the hardware ID and I do show the ID you have listed above and another one:
USB\VID_0D8C&PID_0105&MI_00

Also another thing I noticed with the most recent testing:
When the “USB Multimedia Audio Device” is enabled: I get a “Please Wait…” prompt that last close to 30-60 seconds before getting the “Press CTRL+ALT+DEL to logon” during boot

When the “USB Multimedia Audio Device” is disabled: I do not get the “Please Wait…” prompt I get the “CTRL+ALT+DEL” option right away.


#7

Still researching. Everything about the problem sounds similar to http://answers.microsoft.com/en-us/wi… which appears to be a nasty unexplained issue affecting many Windows 7 users (but just on particular machines/environments).


#8

Hi Tim,

Since disabling the USB Audio device appears to work, and on your system that device is running the Microsoft-supplied driver (so that’s what’s getting disabled), let’s go ahead and see if the C-Media custom driver will fix the problem while still allowing the audio function of the dock to remain enabled.

I consider this a long shot, but this is an unusual problem.

Here’s the driver to install on a test system that’s experiencing the problem: http://plugable.com/public/drivers/C-…

Thanks for letting us know if that appears to help or fix. Again, long shot.

Thanks for your patience!
Bernie


#9

Bernie,
I saw that article as well. I did run a virus scan (even though unlikely culprit since this is happening on several machines) and the system event notification service and the services that it is dependent are started.

I was able to install the custom driver from the link you provided but experienced the same results during testing as in my previous posts.


#10

Hi Tim,

Thanks for that update! Since this is a tricky issue, it may take a while to run it down. I have to believe there’s a relationship with the larger (unsolved) Windows 7 issues in this area. In the interim as a workaround, are your users able to live with the USB audio interface being disabled?

Also, since the C-Media driver didn’t improve things, I’d recommend staying with the Microsoft audio driver, since that reduces the unknowns (keeps it more in the realm of problems that we can call on Microsoft to investigate).

Thanks for the great problem report and follow-up here on this mystery. Thanks for your patience while we work it! Feel free to ping for updates anytime.

Thanks again!
Bernie


#11

Bernie,
Thanks for you time. I have backed out the custom driver. Yes, disabling the audio driver is a good workaround that we can go with.

Thanks,
Tim


#12