ASIX driver on Mac OS Lion and Macbook Air


#1

The HowTo (ASIX on Mac OS Lion with driver package 3.5.0) did not work on my new MacBook Air with Lion. I can’t see any wired network adapter in the network system preferences.

HowTo URL: http://plugable.com/2011/07/27/howto-…


#2

Thanks for posting! Let’s figure out what might have gone wrong …

Did you make it through all the install steps successfully? Or did any errors pop up or anything deviate from our howto (that you noticed)?

Lion has a bunch of new behaviors, so we expect to be updating our howtos as we learn of new pitfalls and how to avoid them …

Thanks!
Bernie


#3

Thanks for the quick answering.

The install process worked fine. No error pop up occurred.

It seems that the install program does not really install anything.
I can not find any .kext files in the asix_temp folder. Shouldn’t the original apple drivers be saved there?

Thanks,
Thomas


#4

Hi Thomas!

Indeed the installation script should have saved the original Apple driver AppleUSBGigEthernet.kext into /asix_temp/

Since the installation completed successfully can you also check whether the ASIX driver is in it’s right position?

It should be under:

If the file is there, can you check it’s file size?

Also what do you get if you type (make sure the adapter is plugged in) :

Once we have this information we can suggest next steps!

Regards,
Lampros


#5

Hi Lampros,

I tried to reinstall the 3.5.0 driver. Now I got a warning message: The system extension can not be used. The extension /System/Library/Extension/IONetworkingFamily.kext/Contents/PlugIns/AppleUSBEthernet.kext was not installed correctly and can’t be used.

When I type kextstat | grep Ethernet I got:

nothing:~ basi$ kextstat | grep Ethernet
95 1 0xffffff7f80e86000 0x5000 0x5000 com.apple.iokit.IOEthernetAVBController (1.0.0d5)
100 0 0xffffff7f80ad0000 0x6000 0x6000 com.apple.iokit.IOUserEthernet (1.0.0d1)
131 0 0xffffff7f8084a000 0x5000 0x5000 com.apple.driver.AppleUSBEthernetHost (2.1.2)

When I look in the /asix_temp/ folder only the AppleUSBGigEthernet.kext is saved there, now. But I have the 10/100 MBit version of the adapter.

Again, when I restart, I can’t find a wired network in the system network preferences.

Regards,
Thomas


#6

Hi Thomas!

Thanks for that and sorry for the very slow reply.

The driver you are using (3.5.0)](http://www.asix.com.tw/download.php?sub=searchresult&PItemID=84&download=driver) is the driver for the Gigabit adapter only - it won’t work with the 10/100 adapter. The right driver should be version (3.4.0).

You need to go back and install the 10/100 driver - found here

Let us know if this helps!

Regards,
Lampros


#7