ASIX 88178 USB Ethernet Adapter on CentOS 6


#1

Hi,

I’ve plugged in the USB ethernet adapter into a CentOS box and it works out of the box with a static IP, but will not get an IP by DHCP. I’ve since tried compiling the drivers as per http://plugable.com/2010/10/18/howto-… without success. Any idea?

uname -r

2.6.32-279.14.1.el6.i686


#2

Hi David-

Unlike Ubuntu using the Aptitude package manager, CentOS uses Yum for package management and installations.

Below is an article on installing a driver on CentOS using Yum- using these steps you should be able to install the same driver package mentioned in our blog: http://www.asix.com.tw/FrootAttach/dr…

http://unix.stackexchange.com/questio…

Hope this helps, please let me know if you’ve other questions.

Best wishes-

Jeff


#3

rpm --import http://elrepo.org/RPM-GPG-KEY-elrepo.org

rpm -Uvh http://elrepo.org/elrepo-release-6-4…

yum install kmod-asix

make install driver package

Problem solved. Thanks!


#4

Hi David-

I’m glad you found the elrepo option. I tried this in a VM yesterday after my initial post (was going from memory on 1st response) and was going to share this if you hadn’t already found it. It crashed my VM (however I think this was a VM issue) so I didn’t want to post publicly without first seeing it work.

Best wishes and thanks for letting us know what worked!

Sincerely-

Jeff


#5

This did not work for me. It says I have the latest module, but then cannot find an IP. I tried both NetworkManager and the default Network, and neither works. I know it is plugged in.

Do we have clear instructions someplace for installing the driver on CentOS 5.9,like the Debian directions?


#6

For CentOS 5.x, you have to import a different repository:

rpm -Uvh http://elrepo.org/elrepo-release-5-4…

yum install kmod-asix

mkdir asix

cd asix

wget http://www.asix.com.tw/FrootAttach/dr…

tar xvjf *

modprobe -r asix

make

make install

modprobe asix


#7

Thanks. Already did all that. I have done literally everything I can think of. Maybe this device does not work as advertised and does not really support Linux. The closest I got was when I statically assigned the IP, but then I don’t have network access.

I am going to install CentOS 6 and see if I have better luck. This machine is young enough that it is not that bad to switch OSs.


#8

Hi Tony (and David, thanks so much for jumping in to assist)-

If we’re not able to find a solution through troubleshooting at the software level it won’t be a problem to setup an exchange.

Please let me know if y ou’ve already updated to CentOS 6 and/or still have questions on the 5.x setup process.

Best wishes-

Jeff Everett
Plugable Technologies


#9

Updating to CentOS 6 solved most of my problems. I can now have both ethernet cards and wireless connected and still keep internet access. My other problems are purely OS related, and don’t have anything to do with this product or driver ( so far ). Thanks.


#10

Awesome Tony, I’m glad to hear you’re up and running!

Please let us know if we can assist in the future.

Best-

Jeff


#11

Dear all,

Now I have trouble with usb2ethernet adapter.

Now, I install CentOS 6.5, Linux kernel 2.6.32.
I AX88772A (http://www.asix.com.tw/download.php?s…)
But I can not install on CentOS. I plug in but can not regconize device (I installed driver as Readme file.
(I installed Linux 2.6.9 v1.2.2 2007-09-11 For Linux kernel 2.6.9~2.6.13)

Best regards,


#12