approximately once a day monitors go black and states adapter failed to load


#1

UD-3900 about once every other day, my monitors go black and it states my adapter failed to load and I have to reboot system to get monitors back up. I have a Win 10, 32GB RAM, with 3 24" monitors. two of which are plugged into the back of desktop and the third hooked up through the UD-3900. Already downloaded and ran the support program and have zip file ready to send


#2

Hi Todd,

Thanks for contacting us. Sorry to hear of the disconnecting monitor issue you are experiencing with our dock and I will be happy to help!

Thank you for the description of the behavior you are seeing. Based off of this we will want to reinstall the DisplayLink software and run the DisplayLink drivers to make sure that the software is in a good state. To do so, please follow these steps:

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely. Please keep it disconnected until the last step
  2. Uninstall the DisplayLink Core software from the Control Panel -> Programs and Features. Don’t worry if this fails, just move onto the next step
  3. Download, extract and run the DisplayLink cleaner tool, found here --> https://s3.amazonaws.com/plugable/bin… and ensure it displays “Cleaning Complete” when done (video walk-through -> https://youtu.be/AcVV1gD_FvI)
  4. Once the Cleaner has been run, reboot (even if not prompted to)
  5. Now download and install the 7.9 M7 DisplayLink software, found here --> https://s3.amazonaws.com/plugable/bin…
  6. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system when prompted by the installer which will trigger the final portion of the installation

If that helps, great! If not, would you be able to send us the Log files that you mentioned you have? We will want to examine logs to see if they can tell us what is happening. Please send them to support@plugable.com with ‘Ticket 146484’ in the subject line so we can match everything up. Unfortunately, we are unable to transfer log files via our support forum interface. We will then examine the logs and determine next steps from there.

Thank you,

David W.
Plugable Technologies
www.plugable.com/support


#3